Arduino Uno avrdude: stk500_getsync(): not in sync

Hi everyone!

This evening I’ve run into some trouble with my Arduino Uno (I think that it’s the original version, there is no mention of any revision on the board) of about 3 years old. When trying to upload I get the error “avrdude: stk500_getsync(): not in sync: resp=0x00”. When uploading the TX and RX LEDs don’t flash. The onboard ON LED burns (meaning that it has power) and when pressing reset the L LED blinks twice and then stays off. There is nothing connected to any of the pins; no shields nor wires.

So far I’ve tried the following:

  1. Pressing reset before uploading (after compiling, before uploading)
  2. Changing the USB-ports
  3. Resetting the IDE and the entire system
  4. Changing the upload device to Arduino Duemilanova (weird suggestion, but I’ll try anything right now)
  5. Removing the drivers from the system, rebooting and reinstalling them
  6. Doublechecking the COM-port

Suffice it to say, I’m getting a bit disheartened. I read somewhere that resetting the Atmega16U2 might work (forumlink) which I’d rather not try unless all else fails.

Just last week the board was working fine. Before it went unresponsive I was trying to make an old LCD Shield from Sparkfun to work. I downloaded the drivers from github, but instead of the actual .cpp, .h and .txt files I needed, I got those files in weblayout (in plaintext that just looked like a bunch of <“header”> “code” <"/header">) when rightclicking and downloading them. The compiler caught the error before uploading, though. After I fixed the library I tried again and then I got the error. Since the compiler caught the error before uploading it might be unrelated, but it’s worth mentioning.

Do you guys have any suggestions I could try before turning to reinstalling the bootloader?

Perhaps something is blown. For example with static electricity or a shortcut somehow.

It seems that the ATmega328p is working.
You could confirm that with a programmer (like a USBasp or Arduino as ISP) and use the ICSP header to upload a sketch with a programmer.

It seems that the data path of the (virtual) serial port via usb is not working. You could rewrite the firmware into the ATmega16u2, but perhaps it is blown and rewriting the firmware might not work.

Erdin:
You could confirm that with a programmer (like a USBasp or Arduino as ISP) and use the ICSP header to upload a sketch with a programmer.

I found something at Sparkfun's website about reprogramming using another Arduino. Is this what you mean? That looks a lot safer (read foolproof) than the other reprogramming method I mentioned in my opening post. I can get an Arduino from my school, but it's probably a Uno Rev 3, not an Uno original. Is that going to be a problem?

Update: this one works with jumperwires and is from the Arduino website

Yes, something like that.
I use a USBasp programmer myself (and an adapter for 10-pin to 6-pin).

Nick Gammon wrote a page about it.

If you want to a Arduino as ISP, you can load the sketch (included with the examples I think) and make the connections.
You could try to upload a sketch to the faulty Arduino, or try to load the bootloader into the faulty Arduino. You don't have to mess around with the optiboot, just use the normal bootloader included in the Arduino IDE.
Set the extra output information on for uploading in the settings.

The problem is: if you get an error, you would not know if it is the faulty Arduino or a bad connection.

If you go through this much trouble, you might as wel buy a new Arduino board. I think it is broken after all.

Update: I read your update. That is indeed the best page for Arduino as ISP. That is working ? You can upload your sketch that way (but no usb, so no serial monitor). The ATmega328P is okay. The ATmega16u2 (for the usb) might be blown, you could try upload its firmware.

this how i fix my ardunio nano
i had the error in my windows 8 os but when i plug in windows xp it works like charm

what i did i copied required drivers from xp for ardunio and put it on my windows 8 and i used the latest arduino software 1.5.2 and it worked for me. u can try plugging into windows xp check whether it works on that os
this may work

thanks

Well, I tried resetting the bootloader with the help of a USBtinyISP a guy at school luckily happened to own, but it didn't do anything. :frowning: Both he and I think my three year old Arduino has just died from use and extensive travelling. At least it went out fighting, just a couple of weeks ago it created 200 MB of environment data in a week long datacollecting assignment. :slight_smile:

I bought a new one tonight, the Arduino Uno SMD version. The shield I used turned out not to be the culprit, it worked perfectly on a school supplied Arduino.

Unfortunately it couldn't be fixed, but still thanks for the help!

I would be interested to know, if the 'broken' board would work as described in the loopback-test thread?
The thread is a sticky on page one of this Forum...

My mega 2560 worked like a charm before those Java/Adobe flashplayer safety-issues started to come up.
Now with every new update, we are in risk of loosing our communication path completely.
Check out, how many avrdude sync-error threads we have here since Christmas 2012...

Installing win98 or XP might help, but do we want that?