Arduino Uno Computer recognizes Uno, but NO COM#

I was seriously hoping I wouldn’t have to post here for help as I usually can figure things out, but after the last week of googling, scanning forum posts, and general frustration, here I am.

First of all, I’m using an Arduino Uno. My main problem here is that when using it, I cannot change the port in the IDE to anything but COM1, which is obviously a problem. My computer recognizes the Arduino Uno in device manager, but as you can see from the image(which I also added as an attachment), it does not assign it a port number. I have tried a large list of things to troubleshoot:

-Unplugging, plugging back in.
-Restarting computer
-Restarting IDE
-Reinstalling drivers
-Deleting old drivers and reinstalling
-Uninstalling IDE, drivers, and reinstalling
-Testing it on 3 other computers, all of which have worked properly
-Installing Versions 1.6.3 of the IDE and up, using both the installer as well as manual zip

I know this board works, as I’ve used it on a number of other computers as I said. Essentially my best guess is simply some sort of communication between the Arduino itself and my computer. If there’s any thoughts or ideas, I would greatly appreciate it and can provide more information where it’s needed.