Arduino Uno - Device not recognized

I started using the Arduino Uno on Sept 28th. However, yesterday it stopped working completely and I started to get this error :

"Windows has stopped this device because it has reported problems. (Code 43)

A request for the USB device descriptor failed."

Steps I’ve tried:

  • I’ve uninstalled the Arduino software on my local computer
  • I’ve shutdown and restarted
  • I’ve tried using a new usb connection cord

None of these things have work. Do you have any suggestions?

There are multiple reasons for this error and the small magnifying glass at the top right will gather those up for you inside google but limited to the forums.

Bob.

This was amazingly unhelpful. I've provided the device model, the error message that I'm receiving and lastly what I've done to troubleshoot.

Further information that may be helpful ... I'm on a windows PC. It was working before and then stopped.

If you'd like additional information and would like to be more helpful please feel free to request additional information.

As an fyi... I've already searched the magnifying glass and YouTube videos to troubleshoot this. Which is where I received the initial ideas to troubleshoot.

Hi,

have you tried in on another PC?

Do you have access to another Arduino to test on your PC

I generally find that no matter what I want, or need, to do, someone else has already done it and the information is out there somewhere.

It sometimes gets a bit tedious looking for a specific problem while trawling through loads of google hits after a search, but I find I'm learning different things as I'm doing it.

Ah, yes, has MS pushed an update onto your PC recently? It annoys me that I have auto updates turned off, and I've set my ethernet as something that 'costs' me to use, but MS still pushes garbage onto my PC that I don't need or want!

I'm hoping they release a 'windows 12' soon so they stop messing around with win 10...

Peter