arduino uno does not recognize the USB/serial port

I have new arduino uno R3 board worked for couple of days and now stopped working. Cannot recognize the USB device. Board green led and pin 13 leds are on. I am using with Adafruit stepper sketches.
Tried with 4 different USB cable, two different computers and different USB ports
Tried with and without the adafruit shield.

When reset button is pressed the pin13 led blinks

Your operating system: Windows 10
What kind of board you have: UNO R3
Problem: Initially everything worked, USB port automatically recognized, was able to download sketches.
Do not know what happened but now USB device is not detected.

Error Message:
Arduino: 1.8.3 (Windows 10), Board: "Arduino/Genuino Uno"

C:\Program Files (x86)\Arduino\hardware\tools\avr/bin/avrdude -CC:\Program Files (x86)\Arduino\hardware\tools\avr/etc/avrdude.conf -v -patmega328p -carduino -PCOM3 -b115200 -D -Uflash:w:C:\Users\eravvee\AppData\Local\Temp\arduino_build_625550/StepperTest.ino.hex:i

avrdude: Version 6.3, compiled on Jan 17 2017 at 12:00:53
Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
Copyright (c) 2007-2014 Joerg Wunsch

System wide configuration file is "C:\Program Files (x86)\Arduino\hardware\tools\avr/etc/avrdude.conf"

Using Port : COM3
Using Programmer : arduino
Overriding Baud Rate : 115200
avrdude: ser_open(): can't open device "\.\COM3": The system cannot find the file specified.

avrdude done. Thank you.

Problem uploading to board. See http://www.arduino.cc/en/Guide/Troubleshooting#upload for suggestions.

i also uninstalled/installed the IDE software.
reboot the windows PC couple of times
Tools -> port is grayed in the menu

Disconnect everything from your board.
Only use USB 2.0 ports.
Double check in device manager that COM 3 is the correct port.

If you cannot see anything in device manager then there is an issue with the board or drivers.

disconnect everything and tried. still the same issue