Arduino Uno Driver issues.

Hi Im brand new to the whole Adruino stuff and need some help. I recently purchased an "Experimenter's Kit for Arduino Uno" and I am having difficulties installing the driver. I have an Arduino Uno R3 and the Arduino IDE cannot communicate with the board. In the Device Manager the device shows up under Other devices as ATmega16u2 DFU and on the board, the green and orange lights stay on, the orange one does not blink. I have tried Update Driver Software in Device manager. Windows 7 searches for driver update but is unable to install driver. I tried doing it manually by selecting the arduino driver folder for where to find the driver but it still wont recognize it. I have tried using a different computer, but the same thing happens. I have FLIP and Arduino installed and my laptop runs Windows 7 Im not sure what I should do Thanks

See this post for DFU mode:,141407.msg1062815.html#msg1062815

The short answer is that if your 16U2 came un-programmed, there is a good chance the main processor is un-programmed as well. So even if you are able to reprogram the 16U2, you still need to figure out a way to program the 328.

I would send it back and see if you can get a replacement.

Thanks for the help

Hello there,

I am facing a somewhat similar problem with the driver installation for my Arduino Uno. As per the Arduino installation instructions, I should see "Arduino (COMxx)" under the Ports (COM & LPT) in Device Manager. But I do not see this. The Arduino Uno is, however listed under "Other devices." If I right click here and choose the "Install driver" option I can manually browse it till the unzipped "driver" folder, but the "ArduinoUNO.inf" file does not show up.

I know that the "ArduinoUNO.inf" file is definitelt there as I can see it if I open the folder manually!

I have tried this with both the 1.0.3 as well as the 0023 versions, but with the same results. BTW, I am using Windows 7.

Can someone help me with this......THANKS!

Steps to install the Arduino drivers in Windows:

Right click the Unknown Device in Device Manager Select Update Driver Software Select Browse my computer for software Click Browse button Select the Drivers folder under the location of your Arduino software installation. (Do not select the FTDI folder inside the Drivers folder) Click OK Click Next

I am experiencing a similar problem

Windows 7 32-bit

I purchased an "Arduino Starter Kit", which included an UNO, a small pile of parts, and the book Getting Started with Arduino.

First connection to the computer I notice Device Manager shows "ATmega16u2 DFU" under "Other Devices".

When I manually install a driver, I get an error code 10 stating the device can not start.

Also, the 'L' LED is not flashing erratically as the book states should happen for a brand new board.

Did I buy a problem? All advice appreciated.

edit: I've used FLIP and now have a functioning USB interface. I've used the Loopback test and verified USB function is now OK.

I get this error now:

avrdude: stk500_getsync(): not in sync: resp=0x00

edit2: UNO replaced by retailer. Works now.

I had this same problem. Here's how I solved it:

Open the device manager, right click the Uno and select "Update Drivers" In the window that pops up, click "Browse my computer for driver software" In the next window, instead of clicking "Browse", click "Let me pick from a list of device drivers on my computer." Tell it to list all drivers, and while it's busy retrieving the list, click "Have Disk." This will let you browse to your Arduino drivers folder and actually SEE the .inf files you're supposed to install. Pick the right one and ignore all of Windows' warnings.

Of course, now that I've done that I have a whole different problem, what with not being able to finish uploading, but the driver seems to be fine.

Good luck!


I can't install the driver either. Windows tells me that the third party INF does mot contain digital signature information.

i'm on windows 8.

any help appreciated.


StuMartin: Hi

I can't install the driver either. Windows tells me that the third party INF does mot contain digital signature information.

i'm on windows 8.

any help appreciated.


The Arduino team has created signed drivers for Win8. This will be included in the next version of the IDE, but you can download it from here:


problem now solved, i disabled digital signatures via troubleshooting menu and then re-installed driver.