Arduino Uno freezes on "uploading" never completes, never fails, no RX/TX lights

Hi all,

I have a brand new Arduino uno and cannot get any code (even an empty file or the "blink" program) to load into it. I turned on verbose upload debugging and the last message to be displayed when I hit upload is Overriding Baud Rate : 115200. Then nothing, no failure messages, no attempts to upload. The RX/TX lights on the arduino never flash.

  • Have tried with Windows 7 32 bit and a mac with osx 10.9.5
  • Power light is on
  • LED 13 flashes as per normal (so bootloader is ok?)
  • USB driver has been manually updated
  • Correct board is selected in TOOLS>board
  • Correct port is selected in TOOLS>port
  • Computer has been rebooted
  • Using 1.6.7 software and 1.6.5 software.
  • Have tried different USB cables
  • Have tried with an external PSU and also just powering off USB.

I've found a lot of other topics where uploads fail for various reasons, but can't find any where the upload never really even starts or properly fails! Any ideas much appreciated, thank you!

Pop the chip out and try another board. It may be the 16U2 chip not doing the work. To check if the chip is alive, connect the board to windows pc, open the arduino>serial monitor,select any random baud rate,the arduino should reset i.e blink the led 3 times. This does not depend on the sketch running on the board. I’m a newbie in respect to firmwares for this chip to be used in arduino, but can suggest to follow this tutorial at your own risk. < Arduino - Upgrading16U2Due > This procedure is used for Arduino Due ,can’t tell if works for Uno.
Cheers,
-Malhar