Arduino Uno Mac OS  Serial Port already in use

I did not think that this would be that difficult, but hopefully someone can help.

I am trying to get my newly acquired Uno to work on my Mac desktop.

I downloaded the software and followed the instructions on the site, but I keep getting the error message serial port already in use.

I have rebooted, reinstalled, tried several of the recommendations on this forum.

What am I doing wrong? Or should I just toss this thing out?

Thanks ahead for your help.

I assume you have installed the OSX USB>Serial drivers, and are selecting the correct serial port on in the Arduino IDE.

Hi Takai

Thanks for reply

I did not install drivers with IDE per directions on arduino.cc for an Uno.

There is nothing in my java extensions.

My USB works fine with my Apple devices and camera.

I do get /dev/tty/usbmodem when I have the Uno installed. It just does not let me upload sketch and gives me serial port in use error.

Cheers

Steve

Do not install the serial drivers, they are not necessary for OSX.

What version of OS X are you running?

Each time you attach the Uno do you get the "A New Network interface has been detected" Popup?

Are you connected through a hub?

While the Uno is connected, run this command in a terminal "lsof | grep usbmodem". What comes back? (It could take 10-15 seconds to complete depending on what is running on your computer.)

I had to install the FTDI USB Serial drivers to get mine working. Comes in the standard Arduino package.

I had to install the FTDI USB Serial drivers to get mine working. Comes in the standard Arduino package

The UNO does not have a FTDI chip on it. So installing the drivers for one would be pointless.

Point taken, didnt realise the Uno didnt have an FTDI chip.

I have 10.6.5 installed.

Yes I get the network pop up and do nothing but click apply.

I have tried it on another USB port, got the pop up, but still get the error.

I do not have a hub, I and direct connect through the back of the Mac.

And the result of running "lsof | grep usbmodem" in a terminal?

I ran that command in terminal and nothing came back...no result

Well that becomes a little suspect.

I am able to reproduce the "serial port in use" error, if I use something else to use the serial port. In which case, lsof (list of open files) points to the process using it.

  1. Do you only have one Arduino Window (or Sketch) open?
  2. How many /dev/usb.usbmodem devices show up in your Tools -> Serial Port Menu (and what are they called)?

ok..I rebooted and ran lsop | grep usbmodem again

This time it came back with

-bash: lsop: command not found

the answers to your questions:

  1. One window open
  2. Two, /dev/tty.usbmodem411 and /dev/cu.usbmodem411

Ok

I made a typo as you can tell lsop versus lsof

it came back with this

vzwwirele 140 srb56 10u CHR 11,11 0t108734 653 /dev/cu.usbmodem411

Are you using some kind of Verzion wireless as your internet connection? "vzwwirele" looks like the name of a process that a Verizon connection device would use. So there are two possibilities: 1) usbmodem411 is your Verizon adapter or 2) the Verizon software is claiming control of anything that looks like a usbmodem.

One option would be to try the command "kill 140". (That means kill process 140. Process id 140 is the number in the column after vzwwirele.)

If your Verizon device and Uno are connected at the same time, this command should return all modem devices:

"ls -l /dev/tty.usbmodem*"

At the very least, you now know there is in fact something using the same device which appears to be your Uno. :wink:

The verizon is for my MiFi

Is there anything I can do to redirect the Arduino or do I have to uninstall verizon?

James thanks

Everything thus far has been very helpful

For what it is worth, I have a Sprint Overdrive (similar to the MiFi, if not the same thing) and I never installed the software that came with it. OS X can use it as a native network device when it is connected, the web interface allows me to do configuration, and it connects via WiFi just fine.

I will uninstall the Verizon

Btw...the kill command worked and it accepted the sketch

My 12 year old son and I thank you

Cheers

Steve

Glad it worked out. :slight_smile: