Arduino Uno not detected, need help!

Hi everyone,

I’m a newbie Arduino User, and here’s my problem,

Before:
My Arduino UNO Rev3 has been working fine until yesterday when I tried to control a stepper motor with and a Polulu A4988 module.

Last thing I did before the problem:
I supplied the Uno board from computer with the USB cable and I connected the 5 V power IO of the Arduino to the VDD of the Polulu module. So I’m pretty sure the problem came from that.
I thought the current draw was too high and a regulator has not supported or the USB-UART module burned or something like that.

Now:

  • The ON and L leds light permanently (L doesn’t blink anymore)
  • The board is not detected by PC anymore, no plug sound.
  • There are only “serial port” and “COM1” in tools ->port of Arduino IDE while there was “COM3” before when I connected the Arduino
  • Nothing appears in “Ports COM & LPT” and not even “Unknown Device” in Device Manager of Windows (I’m using Windows 7 OS by the way)

What I have already tried:

  • Rebooting my computer
  • Uninstalling and reinstalling Arduino IDE and arduino drivers
  • Using another USB port
  • Using another USB cable
  • Using another computer (with Windows 8 OS )
  • Push reset button
  • Using an external power supply
  • Of course unplug and plug Arduino many times
  • Waiting too long time after plugging :slight_smile:

What I suppose:

  • The Atmega 328P Microcontroller died
  • The USB-UART IC converter died
  • A voltage regulator associated with USB power supply burned (if it exists on the board)
  • Probably the least bad is a problem with the Arduino bootloader

First attempt Help for the 4th and 2nd supposition:
I want to try to solve the 4th supposition first but I don’t know how to do it. I have neither a programmer nor another Arduino.
However I have a FTDI USB-UART converter cable and I wonder if it is possible to use it to reprogram the bootloader but I don’t know how.
Or if the problem is the 2nd supposition, using the FTDI USB-UART cable to program directly the Arduino, but again I don’t know how.
I tried to connect the Rx of the cable to the Tx port of Arduino, Tx to Rx, Gnd to Gnd but It didn’t work. As I said I’m a newbie arduino user there are certainly other things to do (jumper to put, … ) ? ? ? ? ? ?

If First attempt fail: Help for the 1st supposition:
Should I buy an Atmega 328P microcontroller with a pre-programmed Arduino bootloader?

Else:
Any other solutions ? ? ? ? ?

Sorry! if it’s too long because I have been trying to search the solution myself before posting here that why I wrote everything to be as clear as possible.

I need your help please, thank you very much in advance.

It is a possibility that you have burnt your board.

Do you have a multimeter? If you do have a go at measuring the voltages of the board's vcc and 3v rails in respect to ground.

Hi,

Thank you for answering SantinoPrice,

Yes, I do check these voltages and all seems to be correct, 3.3V and 5V, ON and L leds light. However I ‘ve just looked the Arduino Rev3 Schematic and I found there’are 2 microcontrollers on the board (I didn’t know that), One is the main Atmega328 (SPDIL footprint) and an Atmega16U2 (QFN footprint) which contains the USB module communicating with computer using CDC USB class.

Because of my computer can’t detect the board so I suppose it's quite likely that the problem came from the Atmega16U2, with a bit of luck maybe there is a problem with its firmware (proved by the fact that the L led is only light instead of blinking) otherwise the IC has burned.

I think it’s possible to flash both microcontrollers on the board.

In any case I would try to find how to flash these microcontrollers (Atmega16U2 first) and after how to program directly the main microcontroller Atmega328 with the USB-UART converter cable I already have.

I still need your help, thanks !!

There are a few ways in which you can flash the 16U2:

  1. Placing it in DFU mode and using Atmel's Flip program to reload the firmware.
  2. Using an ISP programmer and command line to upload the relevant file.
  3. Using another Arduino loaded with Nick Gammon's bootloader uploader to reload the file.

The 16U2 is not connected to the "L" led, however, guides can be found online to help you should you decide to go through with attempting a firmware reload.