Arduino Uno not Getting Power (Did I kill it)

Hello,

I've been using my Arduino Uno for a few days now, but tonight things went awry. I connected my Arduino to the USB port of my computer but was surprised to see that the ON, TX, RX, and L leds were not turning on. I tried uploading code, it didn't work. I also tried it out on the other two ports on my computer, to no avail. So I tried connecting it to another laptop I had hanging around, and something strange happened. The leds all turned on for a split second, then off again. I stared at it for a second, then it happened again. They turned on like that about five times, then the Arduino became unresponsive again.

What's wrong? Is it my computer that is the issue, is my board fried, or is my USB A to USB B cable broken? Thank you for your help!

UPDATE v1: When plugging in the USB B into the Arduino, I now see the green light from the ON led turning on for a split second then slowly fading out. This happens on both the original computer and the other test computer. I tried wiggling it, again to no avail.

UPDATE v2: Sometimes when plugging the Uno in, funnily enough, Windows 10 makes its "something got taken out of the port" sound, and when taking the Uno out, Windows makes its "something went in" sound. Very confused, since it happens only sometimes. The fading green light from update 1 happens frequently now.

Have you tried swapping the cable out? There’s a plague of bad USB cables in the Arduino community; I am suspicious that some of the cables being included in Arduino kits are bad. A dodgy cable that only made good contact while you were pushing it in or something due to a loose internal connection (or bad connector) could have that effect.

Could also be a short somewhere, triggering the PTC fuse as soon as it’s connected…