Arduino Uno not recognised

My laptop is unable to recognise Arduino Uno (Problem code - 01806400), so it can't upload a simple script. I've checked solutions for Windows 8.1 (I have 8.1 Pro), but couldn't understand what did they fix.
The code has been verified multiple times, it's fine.
I suspect that holding the reset button may have caused this issue.

  1. Did it work in the past?
  2. Can you post a link to a solution that you don't understand?
  3. What is the TTL-to-USB chip on your Uno (the small chip closest to the USB port)? Is it square with legs at all sides or rectangular with legs at two sides?

I doubt that very much.

To clarify, are you saying that when you plug your UNO into your laptop with the USB cable, that Windows doesn't detect it. You don't get any USB device connect sound and nothing appears in Device Manager?

Is this a genuine Arduino UNO or a clone device?

Sometimes the clone devices that use the CH340 USB chip can misbehave if the driver installation is corrupted/wrong etc.

  1. Yes
  2. All
  3. What the hell is that

Real arduino, get the sound - IDE can't find it

  1. We don't know what you found :wink: I've never had to deal with 01806400
  2. For communication with a PC, the 328P microcontroller talks to a TTL-to-USB converter on the board that translates the serial data to USB data and that converter is connected via the USB cable to the PC. An original Arduino uses the 16U2 TTL-to-USB converter, clones often use the CH340 and sometimes a FTDI232x or CP21xx chip.

==

So windows does notice that the Arduino is connected; where and when does the error show? In device manager, I assume.

Based on a quick search, 01806400 seems to indicate a driver issue, have you tried uninstalling the driver and reinstalling it again?

Which project are you working on? Anything involving 12V / motors / etc?

To follow up on what @sterretje said: So Win8 detects the board. Which COM port number appears in Device Manager. What is the actual text displayed in Device Manager when it appears? Does this same COM port appear in the IDE?

The thing is, since the computer can't recognise the device, it can't search for its driver.
In fact I have an Arduino Uno made by Geekcreit. But so far I don't think it makes a difference as the board is working perfectly(All lights, ports work).
Before this error I made a binary clock from arduino. It was quite simple and stays attached to my shield.

COM3 shows up in the manager, and I have set my IDE to upload to "Arduino Uno on COM3"
The device manager just says "Unknown device"

Like this one? The chip circled in red is the TTL-to-USB converter; it's probably the CH340.
image
And no, that is not a real one but a clone with a different TTL-to-USB chip.

What does the properties window in device manager tell you; for the CH340 it should be as shown below
image

If it's different, let us know. If it is, I would suggest to remove the driver, download a new exe from CH341SER.ZIP - Nanjing Qinheng Microelectronics Co., Ltd. and install that.

I don't think it can be both COM3 and "Unknown Device" - but I could be wrong! Do you have any other USB-Serial devices plugged into your computer? One of my PCs got confused if I had 2x CH340 based USB-Serial adapters plugged in at the same time. I think it tried to assign the same COM number to both and then neither COM port worked until one USB-Serial adapter was removed.

There was a potentially similar issue a few days ago and uninstalling the device driver helped sort that one out. If you wish to try that solution, then uninstall the driver as suggested, and then plug in your board without installing any new driver. On Win10, the OS seemed to go off and locate the correct driver, install it and all was well. I don't know if Win8 will do the same but it's worth a shot.

Please use complete sentences, or better, quote the lines you are replying to.

Are you saying that this board previously worked? Do you have another board to try?

I've never seen "Unknown Device" associated with a COM port either. I am on Win10 and I have different drivers:

devmon

drvr

It's called "Unknown Device", but in properties, it says its port is COM3 (or something similar)

Did you try uninstalling the device driver? If so, did Win8 go off and find the right one when you plugged the board back in?

It could be a hosed CH340, which is why I asked if he had another board to try. This would tell if the board or the PC was the problem.

Actually, try plugging the board into another PC and see if the Device Manager recognizes it. (You don't need the IDE for this).