Arduino UNO not recognized MacOS 10.13.3

Hi there,

I’ve not used/programmed any Arduino on my new MacBook Pro 2016 (with only USB-C), but I have an old Uno Rev2 (Original) which was always working great.

Today, I try to plug it in, in receives power but isn’t recognized by MacOS. I tried removing Apple FTDI drivers and replacing them by 2.4.2 from FTDI, still nothing (even after reboots).

I’m plugging it via an original Apple adapter USB-C to USB-A. I also tried to manually load the kext files:

➜ ~ sudo kextload -b com.FTDI.driver.FTDIUSBSerialDriver
➜ ~ kextstat | grep FTDI
182 0 0xffffff7f89285000 0x7000 0x7000 com.FTDI.driver.FTDIUSBSerialDriver (2.4.2) E16D9540-AF63-36AD-94C4-B1164FBD6078 <120 53 5 4 3 1>

Then I tried to plug in the Arduino, but Arduino IDE 1.8.5 doesn’t find it and here is a search in “/dev”:

➜ ~ ls /dev | grep serial
➜ ~ ls /dev | grep usb

Any idea please?

Same issue here

There are different ways to find Arduino's serial port in macOS

  • "ls /dev/{tty,cu}.*" should give you some results incliding the Arduino. Fo emaxomple I see "/dev/cu.usbmodem14201" and "/dev/tty.usbmodem14201" among other things

  • You may use the sytem report



  • you should also be able to find the port through "ioreg -p IOUSB -l -b" or "ioreg -r -c IOUSBHostDevice -l" commands