Arduino Uno not working on Windows 7

I recently bought an Arduino Uno Starter Kit. I installed everything according to the instruction. Initially I was able to create a connection with COM3 reflected on the IDE and was able to successfully complete the first tutorial that turned on an LED. Once I started to work on the second tutorial the connection of the Arduino board with the computer was lost. I was not able to see it under the Serial Port in the IDE. After that I checked device manager and could not see it there either. I check the Arduino website for troubleshooting this problem and followed all the steps. Nothing works. I have checked multiple forums online for this problem and I can’t find a solution for it. I re-installed the software and still have the problem. I tried to update the driver according to the website, but I found a couple of problems. I can’t see COM3 in the device manager to update software. I tried to create a new port and it does not work either. I have been looking into different solution for days. This is the first time I post something in a forum. Please let me know how you can help me.


I just unplug the usb cord and then replace it. Occasionally this doesn't work and I have to reset the computer. Win7. Experienced it with Uno, Leonardo, Mega2560 and ProMini. Don't know if it's my setup or the drivers. But in any case, the old 'turn it off, turn it back on' trick works 90% of the time. Also, try plugging it into a different USB port - this should make it available as a different COM port.

i tried it like a hundred times and does not work.

Sounds like it's time to try it on another computer and/or hit the re-order button. I'd also look for a thread with a title along the lines of "10 ways to kill your arduino" to make sure that none of the conditions than generally ensure destruction could have happened.

You can buy a Meeduino Uno for about $12 or $13 on, so while frustrating - it's not (hopefully) a really big deal. I've got the Mega from these guys. It seems just fine. (Mega was about $5 more - cheap considering the extra functionality that may be had with the larger ram and flash - not to mention the extra IO ports)

I read the "10 Ways to Destroy an Arduino" list, but I have not done anything on the list. I think is more of a software/driver issue than a hardware issue. I saw other posts with similar problems, but they do not have general solutions, but specific ones according to their case. I have not seen my specific case in any forum.

My wife has this similar problem. Seems like Win7 turns off all but 1 of the USB ports. Plugging into that 1 port then turns on the others, and she can use them again. I don't see that issue with WinVista. Could be a Win7 setup problem, we've never tried changing anything to overcome this.