Arduino Uno on Mountain Lion—USB device recognized, but no network interface

Just got an Arduino Uno. Out of the box, I've plugged it into my Macbook Pro and the expected "new network interface" dialog does not pop up. As a result, I can't select the serial interface in Arduino application that is needed to upload code.

I see this in system information

ATmega16u2 DFU:

  Product ID:  0x2fef
  Vendor ID:   0x03eb  (Atmel Corporation)
  Version:  0.00
  Speed:   Up to 12 Mb/sec
  Manufacturer:    ATMEL
  Location ID: 0xfa144000 / 7
  Current Available (mA):  500
  Current Required (mA):   Unknown (Device has not been configured)

The tty.usbmodem#### file definitely does not appear in the /dev folder.

I have tried a different USB cable, tried plugging it into a seperate USB hub, tried externally powering it. I even tried running a VM and connecting the arduino to it but even then the "new network interface" dialog was nowhere to be seen.

Any suggestions? Do I just need a new Arduino? I won it as a prize so I'm not sure how easily I'll be able to return it...

It appears your Uno is in DFU mode.

See here for instructions to update the 8u2/16u2 firmware: http://arduino.cc/en/Hacking/DFUProgramming8U2

Make sure you have dfu-programmer 0.6.1 if you have the 16u2.

Thanks for the help! I can now see the device in the menu... but now I get

avrdude: stk500_recv(): programmer is not responding

in the Arduino IDE whenever I try to upload anything. thoughts?