Arduino UNO orange led (L) zeigt ein problem an

Hallo :)

Ich habe ein Problem mit meinem Arduino UNO ich habe ein neues programm auf mein Arduino UNO geladen das vorher schon mal drauf war und da gab es keine probleme aber als die übertragung fertig war ging eine orangene led an und ging nicht mehr aus das Arduino macht seitdem nichts mehr auch wen ich ein anderes programm drauf lade was kann ich tun

Danke im Voraus :)

hier ein bild http://www.directupload.net/file/d/3763/usrwto42_jpg.htm

Marcel87: was kann ich tun

Hast Du mal den "Blink" Sketch aus den Beispielen hochladen? Blinkt die LED damit?

Wir brauchen mehr Input. Dass eine LED am ausgang D13 leuchtet ist erst mal kein Anzeichen eines Defekts, das kann ja so programmiert worden sein. ie sieht denn das Programm aus, was du als letztes hochgeladen hast? Mit welchem Sketch wolltest du das überschreiben? Welche Fehlermeldungen erschienen dabei?

nein ich meine die led direkt auf dem Arduino UNO

Und diese LED hängt an Pin 13! Die wird in Sketches manchmal als Status LED genommen. Von alleine geht die nicht an.

Marcel87: nein ich meine die led direkt auf dem Arduino UNO

Die orangefarbene LED hängt an Pin D13, wenn du dir den Schaltplan des Arduino-Boards ansiehst...

[edit] Da war wohl jemand schneller. ;)

das weiß ich nicht genau aber ich mein die die auf dem bild an ist

hi,

diese LED auf dem arduino hängt an pin13 und ist auch mit diesem ein- und auszuschalten.

was passiert, wenn Du jetzt ein programm (einfacherweise das blink-programm aus den beispielen in der IDE) draufspielen willst?

gruß stefan

hallo jurs

ja wen ich das mache Blinkt sie

Dann zeig mal deinen Sketch her.

Wenn du ganz sicher sein willst, dass sie aus ist, setzte Pin 13 auf OUTPUT und LOW.

hi stefan

wen ich das programm aus den beispielen in der IDE draufspiele Blinkt die led aber wen ich wider das programm vür das LCD draufspiele Blinkt die led nicht mehr sondern bleibt an und es passiert nichts

ja wen ich das mache Blinkt sie

Glückwunsch! Dein UNO tuts.

Benutzt du SPI? Dann ist es völlig normal, dass sie leuchtet/flackert.

Auch: Je nach Bootloader kann es sein, dass sie an bleibt. Dürfte aber egal sein.

Welches LCD? Wie ist das angeschlossen. Auf dem Foto ist kein LCD zu sehen.

moment ich mach mal ein neues bild das lcd ist ein HD44780 1602 LCD Module Display Anzeigen 2X16 Zeichen

Das 1602 wird normalerweise parallel angeschlossen. Eher selten über I2C oder SPI.

Arduino UNO orange led (L) zeigt ein problem an

Das tut sie nicht. Es ist KEINE Fehlermeldung. Außer, dein Code sieht das explizit so vor. Die Leuchte dürfte nichts, aber auch gar nichts mit deinem LCD Problem zu tun haben. Unschuldig. Sie ist frei zu sprechen.

neues bild IMGP0823.JPG - directupload.net

und das programm

/*
LiquidCrystal Library - display() and noDisplay()

Demonstrates the use a 16x2 LCD display. The LiquidCrystal
library works with all LCD displays that are compatible with the
Hitachi HD44780 driver. There are many of them out there, and you
can usually tell them by the 16-pin interface.

This sketch prints “Hello World!” to the LCD and uses the
display() and noDisplay() functions to turn on and off
the display.

The circuit:

  • LCD RS pin to digital pin 12
  • LCD Enable pin to digital pin 11
  • LCD D4 pin to digital pin 5
  • LCD D5 pin to digital pin 4
  • LCD D6 pin to digital pin 3
  • LCD D7 pin to digital pin 2
  • LCD R/W pin to ground
  • 10K resistor:
  • ends to +5V and ground
  • wiper to LCD VO pin (pin 3)

Library originally added 18 Apr 2008
by David A. Mellis
library modified 5 Jul 2009
by Limor Fried (http://www.ladyada.net)
example added 9 Jul 2009
by Tom Igoe
modified 22 Nov 2010
by Tom Igoe

This example code is in the public domain.

*/

// include the library code:
#include <LiquidCrystal.h>

// initialize the library with the numbers of the interface pins
LiquidCrystal lcd(12, 11, 5, 4, 3, 2);

void setup() {
// set up the LCD’s number of columns and rows:
lcd.begin(16, 2);
// Print a message to the LCD.
lcd.print(“Rammstein”);
lcd.setCursor(0,1);
lcd.print(“Forever :)”);
}

void loop() {

}

Marcel87: ja wen ich das mache Blinkt sie

Na bravo!

Dein Board ist in Ordnung, Deine IDE funktioniert! Und die L-LED an Pin-13 Deines Boards funktioniert auch wie sie soll!

Was Du hier als Kommentar im Sketch schreibst:

  • LCD D6 pin to digital pin 3 ...
  • wiper to LCD VO pin (pin 3)

kann ich nicht so ganz glauben, denn bei so einem LCD wird das Kontrast-Poti nicht an einem Daten-Pin angeschlossen. Da ist Dir garantiert etwas mit der Pin-Numerierung des LCD-Boards und der Pin-Numerierung des Arduino etwas durcheinander geraten!

Wenn Du es so verkabelt hast, dass an D3 des Arduino sowohl das Poti als auch ein Datenpin des LCD angeschlossen ist: Verkabelungsfehler!

hallo an alle :)

ich habe den fehler gefunden mein Steckbrett ist kaput :)

danke an alle die mir geholfen haben :) :)

Mfg Marcel87

Steckbrett kaputt? Wie kommste darauf? Also die Teile sollten eigentlich nicht so schnell defekt gehen ;)

ich weiß auch nicht genau was mit dem Steckbrett nicht schtimmt aber als ich es mit einem Messgerät durch gemessen habe hate ich in Manschen pinns kein kontagt dann habe ich ein anderes Steckbrett genommen und dann ging alles wieder :slight_smile: