Arduino Uno Partially Recognized by Mac OS Sierra

I cannot seem to get my Arduino IDE to recognize my connection to the Arduino.

I was running OS X Yosemite before, and I was able to upload a few sketches inconsistently, but then it stopped recognizing the board. The console gave errors to the effect that the device was not recognized and that the port was being disabled.

I have since updated to OSX Sierra. When I check system report, my Mac does not appear to recognize the arduino, and I have not been able to get any response out of the console by plugging in my board. However, I ran USB Prober and did get this listing “Full Speed device @ 5 (0x14100000): … Communication device from unknown vendor” with a manufacturer string "Manufacturer String: 1 “Arduino (www.arduino.cc)”. Please look at the attachments of this post for full report.

I am not sure where to go from here, I have tried reinstalling the FTDI drivers and removing the Mac drivers without success.

Thank You

Uno doesn't use FTDI, only the Nano and Duemilonave (and other older boards) do. Try reinstalling the Atmega16U2 drivers from the Arduino/driver folder.

Could be the Atmega16U2 is dead, or needs reloading as well.

Problem resolved, thanks!