Arduino Uno - Problem using some USB Power Adaptors

Hi all,

I've been testing one of my sketches powering the arduino Uno board directly out of the PC usb port while using the serial for debugging. When I was finally happy with the code I decided to disconnect it from the PC and let it sit alone but using a USB power adapter as the power source. When I did this I noticed that the sketch did not work as expected. It seems like it is not looping. I even tried removing all serial print commands until I understood that the serial output is not blocking (read it on this forum).

After a couple of hours trying to determine what was wrong I decided to swap the USB Power Adapter (notice that all worked well when connected to the PC's USB port). I changed from one I bought at DX.com to a Samsung Power Adapter from my galaxy phone and it worked! The is question is why? :roll_eyes:

I know there is a 5v, a GND, a Data+ and a Data-. On mini usb ports there is an additional ID pin. Does anybody know if the way these pins connect influence the way the arduino board work? I'm guessing I could cut all wires except GND and 5V and get a good working power source. :smiley: I didn't expect to stumble in something like this...

Can you help?

Thanks a lot! :slight_smile:

Regards, Jorge

They should not influence operation unless perhaps the 5V is not able to supply enough current.

It could be that the DX power supply is crappy in two ways:

  • it can't supply enough current
  • it produces a very noisy output, causing the Arduino to go crazy

Hello again,

Thanks for pointing out these possibilities. I guess I should try measuring the output current and find out how much the arduino is drawing from each power adapter. I'll let you know...

Regards, Jorge