Arduino uno problem with compiling

Hello, I just started my experience with Arduino uno board. I wanted to check if everything works fine so i tried to upload the exmaple "blink" program. Sadly i have problems compiling it. I choosed tools->boards-> arduino/genuino uno and tools-> port-> com 3(arduino/genuino uno). This is an error messege i got :

Arduino: 1.8.8 (Windows 10), Board: "Arduino/Genuino Uno"

E:\downloads\arduino-1.8.8-windows\arduino-1.8.8\arduino-builder -dump-prefs -logger=machine -hardware E:\downloads\arduino-1.8.8-windows\arduino-1.8.8\hardware -tools E:\downloads\arduino-1.8.8-windows\arduino-1.8.8\tools-builder -tools E:\downloads\arduino-1.8.8-windows\arduino-1.8.8\hardware\tools\avr -built-in-libraries E:\downloads\arduino-1.8.8-windows\arduino-1.8.8\libraries -libraries E:\downloads\arduino-1.8.8-windows\arduino-1.8.8\portable\libraries -fqbn=arduino:avr:uno -vid-pid=0X2341_0X0043 -ide-version=10808 -build-path C:\Users\Kubiś\AppData\Local\Temp\arduino_build_624236 -warnings=none -build-cache C:\Users\Kubiś\AppData\Local\Temp\arduino_cache_186170 -prefs=build.warn_data_percentage=75 -prefs=runtime.tools.avr-gcc.path=E:\downloads\arduino-1.8.8-windows\arduino-1.8.8\hardware\tools\avr -prefs=runtime.tools.avr-gcc-5.4.0-atmel3.6.1-arduino2.path=E:\downloads\arduino-1.8.8-windows\arduino-1.8.8\hardware\tools\avr -prefs=runtime.tools.avrdude.path=E:\downloads\arduino-1.8.8-windows\arduino-1.8.8\hardware\tools\avr -prefs=runtime.tools.avrdude-6.3.0-arduino14.path=E:\downloads\arduino-1.8.8-windows\arduino-1.8.8\hardware\tools\avr -prefs=runtime.tools.arduinoOTA.path=E:\downloads\arduino-1.8.8-windows\arduino-1.8.8\hardware\tools\avr -prefs=runtime.tools.arduinoOTA-1.2.1.path=E:\downloads\arduino-1.8.8-windows\arduino-1.8.8\hardware\tools\avr -verbose C:\Users\Kubiś\AppData\Local\Temp\untitled1873263207.tmp\sketch_feb17a\sketch_feb17a.ino
E:\downloads\arduino-1.8.8-windows\arduino-1.8.8\arduino-builder -compile -logger=machine -hardware E:\downloads\arduino-1.8.8-windows\arduino-1.8.8\hardware -tools E:\downloads\arduino-1.8.8-windows\arduino-1.8.8\tools-builder -tools E:\downloads\arduino-1.8.8-windows\arduino-1.8.8\hardware\tools\avr -built-in-libraries E:\downloads\arduino-1.8.8-windows\arduino-1.8.8\libraries -libraries E:\downloads\arduino-1.8.8-windows\arduino-1.8.8\portable\libraries -fqbn=arduino:avr:uno -vid-pid=0X2341_0X0043 -ide-version=10808 -build-path C:\Users\Kubiś\AppData\Local\Temp\arduino_build_624236 -warnings=none -build-cache C:\Users\Kubiś\AppData\Local\Temp\arduino_cache_186170 -prefs=build.warn_data_percentage=75 -prefs=runtime.tools.avr-gcc.path=E:\downloads\arduino-1.8.8-windows\arduino-1.8.8\hardware\tools\avr -prefs=runtime.tools.avr-gcc-5.4.0-atmel3.6.1-arduino2.path=E:\downloads\arduino-1.8.8-windows\arduino-1.8.8\hardware\tools\avr -prefs=runtime.tools.avrdude.path=E:\downloads\arduino-1.8.8-windows\arduino-1.8.8\hardware\tools\avr -prefs=runtime.tools.avrdude-6.3.0-arduino14.path=E:\downloads\arduino-1.8.8-windows\arduino-1.8.8\hardware\tools\avr -prefs=runtime.tools.arduinoOTA.path=E:\downloads\arduino-1.8.8-windows\arduino-1.8.8\hardware\tools\avr -prefs=runtime.tools.arduinoOTA-1.2.1.path=E:\downloads\arduino-1.8.8-windows\arduino-1.8.8\hardware\tools\avr -verbose C:\Users\Kubiś\AppData\Local\Temp\untitled1873263207.tmp\sketch_feb17a\sketch_feb17a.ino
Using board 'uno' from platform in folder: E:\downloads\arduino-1.8.8-windows\arduino-1.8.8\hardware\arduino\avr
Using core 'arduino' from platform in folder: E:\downloads\arduino-1.8.8-windows\arduino-1.8.8\hardware\arduino\avr
Detecting libraries used...
"E:\\downloads\\arduino-1.8.8-windows\\arduino-1.8.8\\hardware\\tools\\avr/bin/avr-g++" -c -g -Os -w -std=gnu++11 -fpermissive -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics -Wno-error=narrowing -flto -w -x c++ -E -CC -mmcu=atmega328p -DF_CPU=16000000L -DARDUINO=10808 -DARDUINO_AVR_UNO -DARDUINO_ARCH_AVR "-IE:\\downloads\\arduino-1.8.8-windows\\arduino-1.8.8\\hardware\\arduino\\avr\\cores\\arduino" "-IE:\\downloads\\arduino-1.8.8-windows\\arduino-1.8.8\\hardware\\arduino\\avr\\variants\\standard" "C:\\Users\\KubiĹ›\\AppData\\Local\\Temp\\arduino_build_624236\\sketch\\sketch_feb17a.ino.cpp" -o nul
avr-g++: error: C:\Users\Kubis\AppData\Local\Temp\arduino_build_624236\sketch\sketch_feb17a.ino.cpp: No such file or directory

avr-g++: warning: '-x c++' after last input file has no effect

avr-g++: fatal error: no input files

compilation terminated.

exit status 1
Error compiling for board Arduino/Genuino Uno.

I tried reinstalling the arduino IDE having delated the arduino15 file first but it didnt help. Thank you in advance. :slight_smile:

This sort of error could be caused by your antivirus software. Try TEMPORARILY disabling your antivirus for a single compilation to see if the problem goes away, then turn the antivirus back on. If the problem doesn't occur with the antivirus off you will need to adjust the settings of your antivirus to whitelist the appropriate file, folder, or process so it doesn't interfere with compilation.

Still doesn't compile. :frowning:

Okey i fixed this. The problem was that i have "ś" sign in my acc name, after changing the name, and then users/(username) had to change the path with regedit. everything works fine now

Thanks for taking the time to share your solution Krulicusek. I'm glad to hear it's working now.
Enjoy!
Per