Arduino UNO R2 8u2 Reprograming

Hello. I recivied a replacement for my burned arduino board. i opned the box ,but i recivied a diferent Arduino labeled UNO R2. The problem is the pins for reprogram the arduino uno doesn't exist in the back of board and i cant reprogram the chip like here: http://arduino.cc/en/Hacking/DFUProgramming8U2. how i reprogram the chip?

You'll have to see if HWB from the 8u2 is routed to a pad on that board - it should go to a capacitor that connects to reset pin. I notice the new board has two solder pads below and to the right of where the old pads were...

Hmm, that board sure looks better than the Uno R1 but still a bit autorouted (or someone routing like an autorouter - it's a bit ugly in some places, people just don't seem to do neat routing anymore)

Electrons don't care about neat...

No but I do. Photons don't care about artistic talent, they'll bounce off any rubbish but art is still worthwhile.

It's not just about function in this world. Engineers do function, product designers do design, people who do both criticise both :D

Maybe try this approach: http://arduino.cc/forum/index.php/topic,111.msg759.html#msg759, although I'm not sure which of the two capacitors you'd want to charge.

hi there,

i'm having the same problem as Luigi_xp; my ubuntu lucid is not able to see any device when i plug it in. All soft is updated, but dfu keeps saying "no device present", which tells me i can get my UNO R2 into dfu mode. I have tried the like by hundt (the one for the previous UNO version) but it is not working for me. There no messages from dmesg nor lsusb; the only thing i get from dmesg after trying to enter dfu mode is an overcharge:

[ 544.295874] hub 1-0:1.0: over-current change on port 3 [ 544.396134] hub 3-0:1.0: over-current change on port 1 [ 548.545620] hub 1-0:1.0: over-current change on port 3

Any ideas?? The board seems not to be death: green ON LED shines and L LED blinks when i reset it....

Hello,

'Arduino Uno R2' looks more like 'Arduino Uno SMD' than 'Arduino Uno'. So follow SMD instructions for DFU programming:

all that's needed to enter DFU mode is to briefly short enough to short pins 5 and 6 of the 8U2 icsp connector

Pins 5 and 6 are circled in red in this picture:

When i tried with mine, i used the capitor nearest to the 328 chip, (the power plug side).

mark

markB: When i tried with mine, i used the capitor nearest to the 328 chip, (the power plug side).

mark

Wow -- most capacitors block DC, but yours completely blocked ac ;-)

tastewar Thats what happens when your typing doesn't match your thoughts, and the phone rings and you hit send.

Obviously you understood, and yes capacitors can block AC...., and no they don't block DC.

mark

sorry, Mark, just thought it was a funny typo. Didn't mean to offend.

Latest versions of the Uno have a resistor already mounted between the hwb pin and ground.

this means that you just need to reset the processor by briefly shorting the two pins surrounded the red oval.

We are updating the tutorials.

m

[quote author=Massimo Banzi link=topic=61100.msg444229#msg444229 date=1305658577] We are updating the tutorials.[/quote] Thanks. Info about the existence of R2 revision is needed in arduino.cc webpage.

By the way, are there any other new board revisions? I've read about Ethernet Shield R2 (with PoE), but the same happens; no 'official' info.

The R2 boards should, I think, come with the latest version of the firmware (it should show up as revision 0001 instead of 0000) in the details for the driver (i.e. along with the VID and PID).

tastewar Thanks for the reply. I have now viwed the page using another browser and the highlights are showing, unlike before. I have to say that Windows7 with IE8 doesn't like the reply box, and keeps scrolling to hide your typing....

Mark

My pleasure! Glad you found a browser that works (here), too!

Hi there

Trust me to find the easier solution a day after I found the workaround XD

I know this is late and you probably completed a few projects since this post but as a matter of interest, I used this process on my R2 and it worked:

Copied from http://forums.adafruit.com/viewtopic.php?f=25&t=19751

In order to use FLIP, you must put the Arduino into DFU mode and to do that you must bring the HWB pin of the '8u2 low. You can do that with the points shown in the picture. It is still the same as the PTH Uno, the left side of the capacitor that is directly above the RESET_EN bridge. The steps exactly are as follows. 1. Hold the reset pin of the '8u2 to ground to hold it in reset. 2. While doing that, touch the other wire that is connected to ground to the HWB pin (shown in diagram). 3. After touching HWB to ground and releasing, release reset. The device should show up in Device Manager as Arduino Uno DFU or something like that. The driver will not be installed, install it from this location on your hard drive if FLIP is installed. C:\Program Files\Atmel\Flip 3.4.2\usb. It will remain in DFU until power is removed or it is reset from FLIP. It should then come up as AT90USB82 in device manager. Select that in FLIP, you won't find ATMega8u2. That is how you connect for FLIP.

Differences:

  • On the R2 you have two caps between the RESET-EN and the RX LED. Use the one closest to RESET-EN.
  • The R2 has pins where 'wire1' must go.

It is a much longer route than just shorting out the two pins but I always like to know that there are alternatives available.