Arduino UNO R3 (ATmega328p) doesn't work

So i got this Arduino UNO R3 (ATmega328p) board and it doesn't get recognised by windoes+I can upload on it. I tried multiple Arduino versions, multiple drivers, multiple programmers, but nothing seems to work.
I tried changing the ports, I tried it on other PC s, I tried it on Linux, it doesn't work!
please help me I'm a beginner!

Need more details, for example, when you say multiple programmers does this mean you have tried an AVR programmer as well as programming via USB? Have you tried different USB cables? Does it get recognized in Windows/Linux as a serial device?

Is it an original or a clone?

Does the power led light up when you connect?
What happens in Windows device manager? (Extra) yellow triangles?

it looks original but i got it very cheap so it might be a clone

Does it have a second smaller 16 pin chip on board marked CH340G? If so then chances are it is a clone. This doesn't mean that it won't work, but in order to help we would need further information.