Arduino uno R3 : avrdude: stk500_recv(): programmer is not responding

I loaded up the R3 schematics in eagle and had some boards made and have finally finished populating them. Unfortunately I am having trouble uploading any kind of sketch to the 328P-PU.

The bootloader was successfully installed on both 328P-PU chips. I have tried both the

Arduino-COMBINED-dfu-usbserial-atmega16u2-Uno-Rev3.hex and, Arduino-usbserial-atmega16u2-Uno-Rev3.hex

firmwares for the MEGA16U2.

At this point i am unable to identify why neither board will receive a sketch. Arduino IDE returns,

Binary sketch size: 1,082 bytes (of a 30,720 byte maximum) avrdude: stk500_recv(): programmer is not responding

Any help or insight would be appreciated.

|281x500

This is often error and it has several reasons. Did you made the board yourself?
Try loopback test first if ATmega16U2 works correctly. http://forum.arduino.cc/index.php?topic=73748.0

Thanks for your reply,

I had the boards made at oshpark. I have no reason to believe they did a poor job.

I just conducted a Loop-Back test and both boards received echos correctly.

So, if they echoes both USB converters works. Are you sure about the bootloader? What's about Rx/Tx LED during sketch upload? L LED should blink 3x fast after reset and stay solid after if bootloader is there and no sketch.

This is a video of me attempting to upload a blank sketch to the board. Sorry it’s vertical >.<

To put on the bootloader i used an my Eleven board in arduino to ISP. Selected arduino uno from the board list and burnt the bootloader. The IDE said the bootloader went on fine and when swapping out the chip in the eleven for the new one, it works fine in the Eleven.

Also the verbose output was,

Binary sketch size: 1,082 bytes (of a 32,256 byte maximum)
/Applications/Arduino.app/Contents/Resources/Java/hardware/tools/avr/bin/avrdude -C/Applications/Arduino.app/Contents/Resources/Java/hardware/tools/avr/etc/avrdude.conf -v -v -v -v -patmega328p -carduino -P/dev/tty.usbmodemfd121 -b115200 -D -Uflash:w:/var/folders/jt/z_6_9jpx6bd6j6003tgp04rc0000gn/T/build3060019460670880682.tmp/Blink.cpp.hex:i
avrdude: Version 5.11, compiled on Sep 2 2011 at 18:52:52

  • Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/*
  • Copyright (c) 2007-2009 Joerg Wunsch*
  • System wide configuration file is “/Applications/Arduino.app/Contents/Resources/Java/hardware/tools/avr/etc/avrdude.conf”*
  • User configuration file is “/Users/Shio/.avrduderc”*
  • User configuration file does not exist or is not a regular file, skipping*
  • Using Port : /dev/tty.usbmodemfd121*
  • Using Programmer : arduino*
  • Overriding Baud Rate : 115200*
    avrdude: Send: 0 [30] [20]
    avrdude: Send: 0 [30] [20]
    avrdude: Send: 0 [30] [20]
    avrdude: ser_recv(): programmer is not responding
    avrdude: stk500_recv(): programmer is not responding
    avrdude done. Thank you.

Can you take higher-res pictures? What sort of test equipment do you have available? Have you checked whether there is 5V on the 328 power pins?

The blink pattern on your upload is a bit weird there should only be three flashes; which components did you install in the autoreset circuit? IIRC, the reference schematic has several alternate parts that should NOT be populated. (Hmm. Maybe that was on a previous version; it looks OK now.)

I checked all the power pins and they are receiving the expected 5v.
I probed around the LMV358 and LP2980 also and found the expected voltages there.

I attached a copy of the schematic i am working from with the voltages i found around the place.
I have a logic analyzer, cro and multimeter at my disposal.

Unfortunately i only have my phone with me at the moment, I can take more photos but the quality if kind of potato.

Thanks for all your help.

Arduino_Uno_Rev3-schematic.pdf (164 KB)

if it customize board Use avr pocket programmer to upload your code.

The error come several reason Which i think ok in your case: error comes

1) Tx & rx lines occupied 2) selection of wrong port & wrong board 3)USB hub of differnt make

4) boot loader crashedThis most suspected case ;

On the video, I have not seen Rx LED to blink. NCU has no incoming data. The only thing is reset signal. It seems to be ok. Are you really passed loopback test? Each *of "avrdude: Send: 0 [30] [20]" * should be visible on Rx LED. You can try to connect another terminal to Rx pin (via converter of course) during upload to display data. Second board without 328P can be used to do this (Rx-uploaded to Tx-monitor).

Turns out the Rx LED was shot. Replaced it and it does blink.

I just tried using the eleven board to upload sketches to each of the atmegas without a mega in the eleven board over rx and tx. They all had sketches uploaded properly. I could not use my boards to do the same thing.

I placed an atmega in one of my boards with the blink() sketch on it and all is blinking away as it should. This suggests that i could probably just program them manually over the pins through another working board but that is less than ideal.

Unless i screwed up in my understanding, as i typed in serial monitor i was receiving it back. Seemed like loopback was fine.

I wonder if i have not uploaded the correct firmware to the mega16u2?

Bootloader seems to be working correctly. I think, the problem is somewhere in serial converter part.

Did you upload the correct bootloader? There are two atmega328 bootloaders, and they run at different baud rates.

westfw: Did you upload the correct bootloader? There are two atmega328 bootloaders, and they run at different baud rates.

I hope I did. I selected Uno from the board menu and used the Eleven as an isp programmer to upload it. The chips work and accept sketches when placed in the Eleven which suggested to me the problem might not be the bootloader.

can you share screen shot of bootlader successfully loaded. Along mentioning the which programmer you are choosing