Arduino Uno R3 Board not being detected

my Arduino Uno R3 Board isn't being detected by Arduino IDE. How do i fix this issue?

What IDE version? What OS? What 'Arduino' UNO (Give a link - I doubt you have an Arduino ptoduct), What have you tried so far? e.g. swapped cables, swapped USB ports, tried a different computer etc.

1.8.15, Windows, https://www.amazon.ae/ATmega328P-Development-Straight-Compatible-Microcontroller/dp/B07PFCGYRS/ref=asc_df_B07PFCGYRS/?tag=googleshopp09-21&linkCode=df0&hvadid=406948236959&hvpos=&hvnetw=g&hvrand=16015291903195924514&hvpone=&hvptwo=&hvqmt=&hvdev=c&hvdvcmdl=&hvlocint=&hvlocphy=9047100&hvtargid=pla-936208721734&psc=1, I tried installing drivers and plugging it into diffrent USB3.0 ports

Is it being detected by Windows? Can you see any new device in Device Manager when you plug it in? Have you tried a USB 2 port?

Here is a link to the driver : CH340 Driver

[markd833] yes it is

On the page you linked to it tells you :

it doesnt work :frowning:

It does, download it, extract it and run the CH341SER.EXE file

nope it doesnt, idk why

nvm it does

but tools>ports is grey?????

Restart your computer, then plug in the board. check the device manager for the port number and tell us what it is.

port numbr is 2

Can you open the IDE and check the ports in the menu.

Did this work?

Hi - Did this work? If it did, let us know and accept it as a solution, if not, let us know and we can offer more help.