Arduino UNO R3 Not entering DFU Mode

We got an Arduino UNO R3 with an atmega16u2 and we can't put it in DFU Mode, we tried using the RESET and the GND but nothing happened. Then we tried using the 5 and 6 pin of the SPI, and it nothing happened again. Any help would be appreciated, we really need this!

I give you some pics of the arduino, so you can see it...

Front: http://blog.relixtechnologies.com/wp-content/uploads/2012/07/ArduinoUno_R3_Front.jpeg Back: http://i.ebayimg.com/00/s/NTIwWDk2MA==/$%28KGrHqR,!igFC0muqKN2BQ43%292uT5!~~60_35.JPG

Thanks for your time.

PD: Forgive me if I made a mistake on my writing. Hope you can understand my point

i tried tons of more things, but i got the same result, any ideas?

It's possible that the DFU bootloader is not in the flash.

The only way to reliably update the firmware is to use an ISP programmer or another Arduino as ISP programmer.

Do you have access to either of these?

Can you explain me how to do it without another arduino?

You can use the working Arduino as a programmer and try to reprogram the USB to Serial device on the non-working one.

You can follow this tutorial for using the ArduionISP sketch:

The firmware you want to load on the 16u2 is located in your Arduino software package:
arduino\hardware\arduino\firmwares\atmegaxxu2\Arduino-COMBINED-dfu-usbserial-atmega16u2-Uno-Rev3.hex

You will need to connect the ArduinoISP to the six pin header located in the upper left hand corner, near the AREF label.

This can be done without another arduino? Because I don't have another to use...

I mis-understood your question.

Here are some examples of ISPs for AVR: http://www.pololu.com/catalog/product/1300 (This is the one I use) https://www.sparkfun.com/products/9825 http://www.adafruit.com/products/46

[quote author=Louis Davis link=topic=171421.msg1275542#msg1275542 date=1371046155] I mis-understood your question.

Here are some examples of ISPs for AVR: http://www.pololu.com/catalog/product/1300 (This is the one I use) https://www.sparkfun.com/products/9825 http://www.adafruit.com/products/46 [/quote]

is it possible to program the Uno R3 16u2 with this one?

https://www.sparkfun.com/products/9825

Resolved this problem using the parallel port of my computer, the avrdude tool that comes in "Arduino\hardware\tools\avr\bin" within the Arduino software folder. So restored the Firmaware 16u2 chip with command "avrdude -p m16u2 -c dapa -vvv -U flash:w:firm.hex". firm.hex where is the file that contains the firmware chip.

how did you wire up the Arduino to the computer to get this to work? I seem to be having a similar issue, my UNO is bricked and I'm wondering if re-flashing the 16u2 will solve the issue but I don't have another Arduino as well.

I used this tutorial: parallel as isp http://arduino.cc/en/Hacking/ParallelProgrammer in windows xp. And connect cable on pins of atmega 16u2 in arduino, view http://arduino.cc/en/uploads/Main/Arduino_Uno_Rev3-schematic.pdf for more details. Used command "avrdude -p m16u2 -c dapa -vvv -U flash:w:firm.hex" for resolve the problem of DFU mode. The firmware can be found in paste "Arduino\hardware\arduino\avr\firmwares\atmegaxxu2\"