Arduino Uno R3 not showing up in device manager among other things

Okay I have a pretty big problem. I've been researching for weeks on how to connect my Arduino Uno R3 (with ATmega16u2) to my computer. In fact, I've tried FOUR computers to upload anything to the arduino, with two different USB cables without any luck. I tried almost everything. On the Windows computers, I opened up device manager to see if I could download the right drivers for it, and I don't see an Arduino Uno option or Unknown Device option, even when I show the hidden devices. I tried adding the COM and LPT driver manually with the Add Hardware Wizard and used the arduino.inf driver but got a code 10 error. I tried to upload it on a Mac, but under ports I only get a Bluetooth option. When I plug the arduino into the computers, the lights on the Arduino (power, tx, rx) turn on but I don't get any notification from the computer that something is in the USB port. After that, I got a really good USB cable but still I have the exact same problems. I really, really don't want to buy a new Arduino. Any help would be extremely helpful.

You seem to have tried most of the more common fixes.

However from the badly spaced post (you can use blank lines to space out sections and paragraphs) it may be that you got into a bit of a twist by loading maybe drivers and setting up ports that are / were not needed.

Can you post the PID and VID from the code 10 device information please just to be sure its an Arduino ? To get that open the "properties" for the code 10 device and select "details" then in the dropdown box select "hardware ids"

Also ensure you are using only USB 2.0 ports for this and not USB 1.0 or 3.0.

(deleted)

I had a problem with arduino uno.It came with a blink sketch uploaded in it.When ever i connected uno with pc there was no notification sound and no unknown device in device manager.In a single sentence uno was not communicating with pc, but L led blinks continuously even after reset.After 15 hours of experiment I found a trick and after then uno works normally.uploaded different sketch without any error.Whoever faced this problem can contact me on e-mail/facebook.My email-snehashis.adhikari.007@gmail.com

(deleted)