arduino uno r3 not working

i am working on windows 7, 64 bit machine…my arduino was working fine till i connected a 12v adapter to power my motors but after that my arduino doesn’t connect to the computer…i have tried re-installing ftdi vcp drivers…even re-installed arduino IDE
all other arduino works fine on my machine…
so i think the board has been damaged…is there anything i can do??

What was the last sketch you loaded, and does it still do roughly what it is supposed to do?

I have the same truble today!

Where did you connect 12V to?

12V? I have connect my bord whith usb but is not responding.

The OP's problem was after he connected 12V.

If you have a different problem, read the threads at the top of the forum, then post a new thread with a description of your problem, which Uno you have (a link to where you bought it from), what operating system, and what you have tried so far.

@chilliTronics
i pressed the reset button later so now i guess nothing is there..
i connected 12v to the power jack provided on the board..