Arduino Uno R3 works on Home PC but not in Car :(

I had my Arduino Uno R3 working perfectly as a HID Keyboard (using steering wheel control key presses convert to key outputs) on my Home PC. I went to use it in my Car PC and netbook and it just seems to lock up on both....... Do I/Should I need to use any drivers or application software to get it working i.e. Arduino App??

Thanks in advance, Dave

Any guesses?

How are you powering the UNO?

Keith's on the right track here. If you're applying 12v directly from say the accessory outlet, it may be a better idea to use a 12-to-9v regulator and feed that to the Arduino's barrel connector. Or buy/build a proper car PSU and connect directly to the 5v input.

Lots of electrical noise and damaging voltage spikes in automotive electrical systems. See this thread: http://forum.arduino.cc/index.php?topic=190452.0

Dave,
Is the car PC loading the USB driver for the UNO R3?

DaveOne: Do I/Should I need to use any drivers or application software to get it working i.e. Arduino App??

It is possible that the other PCs are respecting the USB protocol, which is to only provide 100mA of current to a device that isn't enumerated (and hasn't asked for more). Assuming it's Windows on the PCs, you might try setting up the Uno's "driver" so that Windows knows it wants 500mA.

In a car, it is most likely a power issue. It would be very helpful to provide a schematic (even hand drawing) of what hardware you have connected and how.

Also, you might as well post your code (between [code][/code] tags).