Arduino Uno Rev3 : avrdude: stk500_getsync(): not in sync: resp=0x00

Hi, I am having some problems with my arduino and was hoping someone could help me as I have already tried everything I can think of. When trying to upload a sketch I always receive the error code "avrdude: stk500_getsync(): not in sync: resp=0x00".

This started after I had uploaded a modified version of Mike Stirling's flashrom programmer which was compiled and uploaded to the arduino manually. Things I have tried so far include:

1: I tried three separate computers with a combination of known working cables, all fail to upload sketches. I can distinctly see where before uploading the board reboots (indicated by the L led flashing 3 times) and then the Rx led flashes another 3 times before it gives the error.

  1. I then went on to trying a loop back test. This failed, I could again see the Rx Led on the Arduino blinking but the Tx led stays off.

  2. The next thing i tried was re-uploaded the Uno's bootloader, via the IDE using a parallel programmer thinking I had over-written it when i uploaded the previous program.

  3. Still being unable to upload through the IDE I uploaded a slightly modified "blink" sketch using the programmer to see if the ATmega328 was still functional. This worked and I reloaded the bootloader after this test.

  4. Thinking that the problem had to be the atmega16u2 I downloaded flip and uploaded the "Arduino-usbserial-atmega16u2-Uno-Rev3.hex" firmware. This produced no change.

  5. I then reloaded the "Arduino-COMBINED-dfu-usbserial-atmega16u2-Uno-Rev3.hex" as per this thread via the parallel programmer with the following command:

avrdude -c dapa -p m16u2 -P /dev/parport0 -v -e -U flash:w:Arduino-COMBINED-dfu-usbserial-atmega16u2-Uno-Rev3.hex:i -U lfuse:w:0xEF:m -U hfuse:w:0xD9:m -U efuse:w:0xF4:m -U lock:w:0x0f:m

This again made no change.

  1. I again tried the loopback test shorting the Rx and Tx just ahead of the resistor pack as suggested here. This worked and I received the exact string I had typed.

  2. This led me to believe that both the Atmega16u2 and 328p are working correctly but there is some problem in the communication between each. I then used my DMM to attempt a continuity test between the points referred to above and the Tx and Rx breakout points as well as pins 31 and 30 on the Atmega328p. Each test returned a resistance of 1.03k which is the same as the resistance of the resistor itself.

At this point I am unable to think of what could possibly be wrong. Can someone with a bit more knowledge on this topic give me a bit of advise please? I am in the process of ordering another Arduino but I would really like to see if i could learn why this failed and recover it if possible.

Edit: I should mention that the board is a Make Special edition SMD version and so I was unable to test it with the mega328p removed, the best I could achieve was to try it with the reset and gnd pins connected and also another time with the reset button held down.

Haven't gotten a reply on the thread and so I have decided to just continue using it by programming the chip through the ISP interface. I also found this: Self-ISP on an Uno thread that has made that task a bit easier in my opinion.

I used the "16u2-uno-r3-dfu-isp.hex" file and uploaded it through Flip using the process outlined here: Arduino - DFUProgramming8U2. It has been working flawlessly so far.

I must say that one odd thing I observed was that when I modified the "blink" sketch to blink leds on pins 1 and 2, the led on pin 2 would blink while the one on pin 1 would stay lit constantly. This has led me to believe that it is actually the ATmega328 that is damaged and since replacing it is beyond my capabilities at the moment I will just have to use it as is for the time being.

problem - avrdude: stk500_getsync(): not in sync: resp=0x00

solution for was , connect arduino to 12v power adaptor and uplioad , works fine :slight_smile: