Arduino Uno Rev3 not detected by pc/ when powered runs last code continously

Hi all!

My arduino uno r3 board is no more recognised by the computer. When a connect it with the usb cable to the pc:

  1. the option ports under tools is greyed out, so I cannot upload code.
  2. it is not found with device manager neither under COMxx nor as other devices
  3. it does not make the characteristic beeb sound when you connect-disconnect usb device or other arduino boards to pc.

I have tried the following without success:

  1. different usb cable and port and different computers (windows 8 and linux ubuntu)
  2. connecting-disconnecting the board multiple times.
  3. using the reset button alone or by pressing it and leaving it with different combination while connecting-disconnecting the board and starting/closing the ide and trying to upload “empty code” to reset it .

All these were found in the internet as possible solutions but nothing worked in my case.

The board runs continuously the last uploaded code (code was controlling servo motor and when I connect the servo to the board it works just fine).

Does this mean it is stuck in an endless loop? Could you please tell me how I can have access again to the board to be able to appload new programms?

Any help/advice would be much appreciated!

Dimitris

Are you able to burn the bootloader?

Hi and thanks a lot for your quick reply.

Sorry for not answering earlier but I was trying to find a way to burn the bootloader, siche I did not have the equipment needed. Finally I managed to get to my hand a new arduino board and I tried to burn the bootloadr by following the instractions on this site https://learn.sparkfun.com/tutorials/installing-an-arduino-bootloader and bu using the second new arduino board.

When I try to burn the booloader I get the following error messages:

programmer AVR ISP

avrdude: stk500_recv(): programmer is not responding avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x03 avrdude: stk500_recv(): programmer is not responding avrdude: stk500_getsync() attempt 2 of 10: not in sync: resp=0x03 avrdude: stk500_recv(): programmer is not responding avrdude: stk500_getsync() attempt 3 of 10: not in sync: resp=0x03 avrdude: stk500_recv(): programmer is not responding avrdude: stk500_getsync() attempt 4 of 10: not in sync: resp=0x03 avrdude: stk500_recv(): programmer is not responding avrdude: stk500_getsync() attempt 5 of 10: not in sync: resp=0x03 Problem uploading to board. See http://www.arduino.cc/en/Guide/Troubleshooting#upload for suggestions. avrdude: stk500_recv(): programmer is not responding avrdude: stk500_getsync() attempt 6 of 10: not in sync: resp=0x03 avrdude: stk500_recv(): programmer is not responding avrdude: stk500_getsync() attempt 7 of 10: not in sync: resp=0x03 avrdude: stk500_recv(): programmer is not responding avrdude: stk500_getsync() attempt 8 of 10: not in sync: resp=0x03 avrdude: stk500_recv(): programmer is not responding avrdude: stk500_getsync() attempt 9 of 10: not in sync: resp=0x03 avrdude: stk500_recv(): programmer is not responding avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0x03

I have tried the different programmers under tools but it was still unsuccessful. Do you have any other recomendations or any idea what all these errors mean, because I cannot understand them?

Thanks again!

I recommended to use avr pocket programmer from sparkfun. Use in stallion guide from web site.

Error you getting usually because of bootloader.

I would like to know what kind of experiment you are doing. Have you connected any motor sheild as interface Because since you telling USB not regnosise u might destroyed USB to TTL converter ic. When you connect USB device to laptop is ic gets heats up If yes its time to replace it.