Arduino Uno RFID-RC522

Hi, straight to the point. I am having a problem with coping with my card(Mifare Classic 4k) I want to copy my card then later repaste. I have tried it with my friend phone, with an app called Mifare classic tool it worked fine. I could copy the dump info and write it again.
I have the key for it.

I am using Github/RFID-Cloner.ino
I put my key inside the code and uploaded it. But when I try to clone anything it doesn’t come up. As you can see in the image, I’ve provided.image

I have tried with other tags like 1k
(I don’t want to change the UID, just the data)
And yes, everything is connected right, i tried dumbinfo.ino it worked fine. But I can’t put my key in so it just comes up as failed. But I’ve tried with other codes it worked fine.

And this is what i get, i try to scan the card but nothing comes up

Try the most used default keys to print block 0 to 63 of a MIFARE PICC.
1.Read card 
2.Write to card 
3.Copy the data.
Read the card
Insert card...

thanks
appreciate any help

code.txt (10.4 KB)

Better to just copy the text into your posting, using "code" tags.

Sorry, fixed