Arduino Uno - Sketch won't start/saved after power off


I have problem with my Arduino Uno SMD, If I upload the program it works fine, when I unplug the USB then plug back in, I get the flashes on L led (pin 13 led) and the sketch will not run. hitting reset doesn't help. I have to re-upload the program every time I plug the Arduino Uno. seems like the sketch can not be kept in memory after unpluging the board. But while the board is pluged if I hit press button it will reboot and run the sketch. It doesn't matter which code I am using, it's the same behaviour even for sample blinking code. any one have any idea about this issue?

But it was working fine for first few test. I was able to control my servo and also dc motors but after few times, now I have this problem. can any one help me with this issue?


Hope this is a answer… youre not alone…

Welcome in the Arduino Community!

Greetings ChrisS

Hi Chris,

Thank you for your help, yes my board serial number is in that range. Maybe I am going to buy Pocket AVR Programmer from sparkfun to fix it my self. so the only problem is that bootloader thing?

can you tell me is there any special procedure to unplog the board as there is no safe remove for it? I thought that I have damaged the memory part during pluging and un pluging.

Thanks, Mani

Hello, i think your board is fine.

Plug/Unplug will do no damages...

Do you know what an isp is, and do you got one?

The only thing is to "burn" the right / actual bootloader to the board, and everything would be fine and running.

Greetings ChrisS

1 Like

I have the same problem, and Im a total noob and have no idea on how to fix this :(

If you're having this problem, you should be able to contact your distributor (probably SparkFun) for a replacement.

The board isn't actually forgetting the sketch; instead, the bootloader is getting stuck in an infinite loop on startup. The fix to the bootloader source code was actually rather simple, but reflashing it requires an ISP.

I received one of these boards, re-flashed it with a quickly homemade parallel ISP programmer ( ), worked fine :)

I am very new to this and i uploaded the code to my Arduino Uno but it does nothing once it is uploaded please help

I just received two Arduino Unos with SMD chips instead of DIP. I have the same problem, when removing the USB connector and re-connecting it the board goes into the "Hello" blinking. However, if I removed the USB cable, and then power the board with external power my preloaded sketch runs! It was not lost. FYI, Dave

Dave I have exactly the same problem. I also tried to re-burn the bootloader using usbASP programmer. Nothing, it keeps going into “Hello” mode when powered by USB. On the other hand, if I connect it to an external mobile phone 5V charger, it works fine and the sketch loads and runs perfectly. Also I noticed if I click on the Serial Monitor tool, the sketch loads and runs. If I close the Serial Monitor tool, it goes back to LED blink “Hello” mode.

Has anyone found a solution for this?

AlgoryThm, which version of the IDE are you using? If it’s 1.6.8, there is a known issue that it keeps on resetting the board; either go back to an older version or to a newer one (if it exists, not sure; ‘heard’ something about 1.6.9).

Do not bump threads from 2011. Can a mod split the posts from today off or something?

The top of this thread is totally unrelated to the issues being discussed in it today.

Re: versions - there's a bug in 1.6.8 on windows. If Arduino is plugged in while IDE is running, the arduino is continually reset. Use 1.6.5r5 if you don't want to deal with IDE bugs - it's by far the best version available now. 1.6.9 isn't out yet, but hourly builds are available if you want to deal with cutting edge bugs (they do fix the serial bug at least).