arduino uno suddenly stk500_getsync problem, only able to upload one time

Hi
I have a new arduino uno. I tried it out and things were fine.
I DID download the blink test program it worked FINE no problems.

About 5 minutes later I tried to download the blink program again. I pressed upload and this time I get the error :
avrdude: stk500_getsync():not in sync: resp=0x00
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51

So NOTHING has been changed on the system at all.

I have now tried almost all the different strange "solutions" with resets etc. and nothing is working. I've installed the drivers again, reboot, etc. etc. board still just seems to be running the BLINK program when it starts up (L is blinking all the time now since i've loaded that blink program the first time) but it will not accept any upload. I get the same error.

Seems in all the posts no one has found a real solution to this issue. Seems like a major problem with Arduino Uno - not impressed so far. I've work with lots of other dev boards.

running XP

any thoughts how to fix this?

More info:
Binary sketch size: 1018 bytes (of a 32256 byte maximum)
C:\arduino\arduino-0023\hardware/tools/avr/bin/avrdude -CC:\arduino\arduino-0023\hardware/tools/avr/etc/avrdude.conf -v -v -v -v -patmega328p -cstk500v1 -P\.\COM6 -b115200 -D -Uflash:w:C:\DOCUME~1\ADMINI~1\LOCALS~1\Temp\build7023160783197577969.tmp\Blink.cpp.hex:i

avrdude: Version 5.4-arduino, compiled on Oct 11 2007 at 19:12:32
Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/

System wide configuration file is "C:\arduino\arduino-0023\hardware/tools/avr/etc/avrdude.conf"

Using Port : \.\COM6
Using Programmer : stk500v1
Overriding Baud Rate : 115200
avrdude: ser_open(): setting dtr
avrdude: Send: 0 [30] [20]
avrdude: Send: 0 [30] [20]
avrdude: Send: 0 [30] [20]
avrdude: Recv:
avrdude: stk500_getsync(): not in sync: resp=0x00
avrdude: Send: Q [51] [20]
avrdude: Recv:
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51

avrdude done. Thank you.

Also, I tried a loopback test to see if TX and RX is working (while keeping the reset line active).
The loopback test worked, but the device still does not accept an upload.
What I typed was echoed back to me. So the serial communication is fine...

Other things to try?

I've seen a post to Adafruit where they said it was a defective arduino - could this be it?
Any other tests to try?

I just started with an Arduino UNO this week and have run into the same problem. In addition to what has been described above, i cannot find the Arduino in the Device Manager nor COMs anymore.

Problem solved: Did loop back as sugested at the begining of this section and looked for a port that would work. In my case serial port 12 works. All working well now.

Yes, this thread isn't related to COM port issues. My device is online as I stated.

My problem still isn't solved, I need to get something to program the bootloader again - that is my only guess right now.

What bootloader is best to use for the UNO (version 1 board)?