Arduino UNO - TCA9548A - ADXL345 PROBLEM

Hi to all.

I have connected an Arduino UNO, one TCA9548A multiplexer and two ADXL345 accelerometers (manufactured by Sunkee). I have attached my wiring layout. I am trying to run the code you have shared as an example under the TCA9548A heading. The only change I made on this code was the serial monitor’s data transfer speed because I was getting gibberish “Serial.Begin(9600)”. My two ADXL345 accelerometers are not being recognized at all.

I used/tested a second TCA9548A multiplexer with the same results, no device was detected.

I used Adafruit’s code at https://learn.adafruit.com/adxl345-digi … rogramming. I tried to run just one directly accelerometer directly from the Arduino. I run their “sensortest” code and the output was as expected (pasted below).

I would like to mention that the two Sunkee ADXL345 accelerometers have a static address, 0x53. The protocol I’m using to read them is I2C.

Can someone please help me?
Thank you,

Accelerometer Test.


Sensor: ADXL345
Driver Ver: 1
Unique ID: 12345
Max Value: -156.91 m/s^2
Min Value: 156.91 m/s^2
Resolution: 0.04 m/s^2

Data Rate: 100 Hz
Range: +/- 16 g

X: 0.31 Y: 0.78 Z: 9.53 m/s^2
X: 0.31 Y: 0.82 Z: 9.57 m/s^2
X: 0.31 Y: 0.78 Z: 9.65 m/s^2
X: 0.27 Y: 0.78 Z: 9.61 m/s^2
X: 0.31 Y: 0.78 Z: 9.61 m/s^2
X: 0.31 Y: 0.78 Z: 9.57 m/s^2

So, I just run I2CScanner from the Arduino Playground and this is all I got,

I2C Scanner
Scanning...
No I2C devices found

Scanning...
No I2C devices found

Scanning...
No I2C devices found

Scanning...
No I2C devices found

I replaced the multiplexer with a second one I have and I got the same result.

I connected the Sunkee ADXL345 accelerometer directly to my Arduino UNO and re-run the I2CScanner program. It found it at the address 0x53 as it was expected. I have started to believe that the two Adafruit TCA9548A I received are DOA.

Any thoughts anyone?

have you found an answer for this. I use the scanner referenced here: Wiring & Test | Adafruit TCA9548A 1-to-8 I2C Multiplexer Breakout | Adafruit Learning System .

But just gibberish is produced. I plug into 5v, gnd, sda (a4) and scl (a5) on Arduino uno r3

The best Ive gotten is a statement that the tca is present which is then followed by gibberish.....

Thanks