Arduino Uno Upload Failed

Arduino: 1.8.13 (Windows 10), Board: "Arduino Uno"

Sketch uses 1896 bytes (5%) of program storage space. Maximum is 32256 bytes.

Global variables use 188 bytes (9%) of dynamic memory, leaving 1860 bytes for local variables. Maximum is 2048 bytes.

An error occurred while uploading the sketch

avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x5f

avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 2 of 10: not in sync: resp=0x5f

avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 3 of 10: not in sync: resp=0x5f

avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 4 of 10: not in sync: resp=0x5f

avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 5 of 10: not in sync: resp=0x5f

avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 6 of 10: not in sync: resp=0x5f

avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 7 of 10: not in sync: resp=0x5f

avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 8 of 10: not in sync: resp=0x5f

avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 9 of 10: not in sync: resp=0x5f

avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0x5f

This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.

Arduino Uno
CH340G(205695A24) Chip
Atmel; Mega328P(U-Th; 35473D; 20139BJ) Chip

Hello there, I've purchased Uno board from Alliexpres and it arrived few days ago, since then I've been trying to connect it to my PC (Win 10; 64 bit), but still no success. I've tried installing all different kinds of drivers (including the one for Ch-340) but still didn't manage to upload simple sketch to my board. I'm new to Arduino and don't know much about it, so I would appreciate some help. Thanks!

Remove any connections to pins 0 and 1 on your Arduino board. These pins are used for communication with your computer, including uploads. Connecting anything to these pins can interfere with uploads.

Make sure you have the correct board selected from the Tools > Board menu.

Make sure you have selected the port of your Arduino board from the Tools > Port menu.

If you don’t know which port is your Arduino board, you can find it like this:

  • Unplug your Arduino board from the computer.
  • Tools > Port
  • Note the ports, if any, listed in the menu.
  • Close the Tools menu. The ports list is only updated when the Tools menu is re-opened, so this step is essential.
  • Plug your Arduino board into the computer.
  • Tools > Port - The new port listed in the menu is your Arduino board.

Thanks, I'll try it now.

avrdude: Version 6.3-20190619
Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
Copyright (c) 2007-2014 Joerg Wunsch

System wide configuration file is "C:\Program Files (x86)\Arduino\hardware\tools\avr/etc/avrdude.conf"

Using Port : COM3
Using Programmer : arduino
Overriding Baud Rate : 115200

Did all of the steps, but it failed uploading.

you should look in device manager and search for ports (COM&LPT) there should be a device with a name and (comNUMBER) you should set it to this com port and it should upload.

in my case when I have nothing plugged into my USB ports there’s one com port left. and i can’t upload to that com port.

Yeah, checked that several times, right port is selected. May it be something up to drivers? I have CH-340G chip and I installed the right driver I guess (driver link---CH340 Drivers for Windows, Mac and Linux).

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.