arduino UNO Uploading issues

Since upgrading to Version 1.8.10 (Windows) I’m unable to upload to my UNO board with the following error message.
The previous Version worked fine.
BTW my DUE works fine and have no upload issues.

Arduino: 1.8.10 (Windows 7), Board: “Arduino/Genuino Uno”

Sketch uses 3320 bytes (10%) of program storage space. Maximum is 32256 bytes.
Global variables use 369 bytes (18%) of dynamic memory, leaving 1679 bytes for local variables. Maximum is 2048 bytes.
java.io.IOException: Cannot run program “REMOVE/bin/avrdude”: CreateProcess error=2, The system cannot find the file specified
at java.lang.ProcessBuilder.start(ProcessBuilder.java:1048)
at processing.app.helpers.ProcessUtils.exec(ProcessUtils.java:26)
at cc.arduino.packages.Uploader.executeUploadCommand(Uploader.java:129)
at cc.arduino.packages.uploaders.SerialUploader.runCommand(SerialUploader.java:383)
at cc.arduino.packages.uploaders.SerialUploader.uploadUsingPreferences(SerialUploader.java:197)
at cc.arduino.UploaderUtils.upload(UploaderUtils.java:77)
at processing.app.SketchController.upload(SketchController.java:732)
at processing.app.SketchController.exportApplet(SketchController.java:703)
at processing.app.Editor$UploadHandler.run(Editor.java:2075)
at java.lang.Thread.run(Thread.java:748)
Caused by: java.io.IOException: CreateProcess error=2, The system cannot find the file specified
at java.lang.ProcessImpl.create(Native Method)
at java.lang.ProcessImpl.(ProcessImpl.java:386)
at java.lang.ProcessImpl.start(ProcessImpl.java:137)
at java.lang.ProcessBuilder.start(ProcessBuilder.java:1029)
… 9 more
An error occurred while uploading the sketch

This error indicates you need to take some drastic action. Be aware this is somewhat advanced and will remove any boards you have installed via Boards Manager:

  • (In the Arduino IDE) File > Preferences
  • In the Arduino IDE, click the link on the line following "More preferences can be edited directly in the file". This will open the Arduino15 (or similar name depending on OS) folder.
  • Delete all files and folders under the Arduino15 folder except for preferences.txt. Please be very careful when deleting things from your computer. When in doubt, back up!
  • Restart the Arduino IDE

Verify that you can now use your board before reinstalling any packages via Boards Manager.

Hi
Thanks for the reply. I managed to get it to work by downloading a device driver for UNO WiFi Rev2.
Don't ask me why, maybe it downloaded avrdude in the process. But now it works.

Yes, that's what it did. The Uno's hardware package (Arduino AVR Boards) and the Uno WiFi Rev2's hardware package (Arduino megaAVR Boards) both use avrdude.