Arduino Uno & USB 3.0

Tried installing Uno on Win 10 using a USB 3.0 port. Board was not recognized in Device Manager, nothing under Ports, etc. Switched to a USB 2.0 port and everything worked perfectly. Is this a compatibility issue or is it me as a first time user? I searched and searched (Google) and could not find anything on Arduino & USB 3.0. Thank you.

USB 3.0 has tons of backwards compatibility issues in general. Seems to depend on the chipset and/or drivers. Use USB 2.0 ports if you have problems.

I have one system where USB 3.0 ports work fine for everything (which is good, since that's all it has), one where most things work on them, but a few development boards aren't recognized, and another one where the USB 3.0 ports work for hobby electronics stuff - but HID devices are only recognized in the USB 2.0 ports. And the first computer I had with USB 3.0, nothing except USB 3.0 devices worked in the USB 3.0 ports. The pattern seems to be that the older the implementation of USB 3.0, the worse the compatibility.

Thank you DrAzzy for your reply. Experience is a great teacher!