Arduino UNO 'USB Device Not Recognized'

I have encountered a problem with 3 Arduino UNO boards, 1 UNO R3, 1 UNO and one SainSmart board. They have all failed the same way, with the following error report generated by Windows 7 64bit;


"USB Device Not Recognized" One of the USB devices attached to this computer has malfunctioned, and Windows does not recognize it. For assistance in solving this problem, click this message.


I've tried connecting one of the suspect boards to another computer and received the same error message.

The strange part is, all of these boards (3 and counting) have worked upon initial installation, they all seem to fail while a program is being downloaded. The program that I'm downloading does make it on to the chip, but that is the last communication with the board, after that I just get the 'USB Device Not Recognized' error. These 3 failures have all occurred within the last week, and all of the boards are less than a month old. I purchased these boards from 3 different places as well, Digikey, Amazon & the latest one a local hobby shop.

I've invested in 3 of these boards and it appears I can't communicate with any of them. I don' t believe this to be a driver problem, I think it is a hardware problem. The proof of this is that I can plug in a new board and my CPU will most certainly recognize it, but if I plug one of my suspect boards in it will not.

Has anyone else experienced this problem and been able to rectify it? Has anyone had experience returning boards for replacement?

Thank you in advance.

did you use the same usb-port? have you selected the corrcect "com"-port in your arduino-ide?