Arduino Uno WiFi not working

I have bougth an Arduino Wifi board and I am trying to implement a socket based communication between this borad and a PC. I have used this software on an Arduino board with an wifi-shield. No I am using the same software in combination with the WiFiLinh.h library on an Arduino Wifi borad and it seems that there is no chance to get it working.

Has someone any idea, how I could get the board working? Does somenone know, when ther will be a working version of the WiFiLink.h library available?

Kind regards Gert

Please post a link to where you found this WiFiLink library (using the chain link icon on the toolbar to make it clickable) or if you installed it using Library Manger(Sketch > Include Library > Manage Libraries) then say so and state the full name of the library.

Hello Pert,

thank you for your reply!

I am using the Arduino IDE version 1.8.3 and I have downloaded the WiFi Link library version 1.0.1 using the library manager of the IDE. I have no idea, where the library manager got it.

Kind regards

Gert

schwingshakl: it seems that there is no chance to get it working.

Please explain exactly what the problem is that you're having.

Hello pert,

I have tested the following setch:

#include <WiFiLink.h>

void setup()
{
//Initialize serial and wait for port to open:
Serial.begin(9600);
while (!Serial)
{
; // wait for serial port to connect. Needed for native USB port only
}

if (WiFi.status() != WL_NO_WIFI_MODULE_COMM)
{
Serial.println(“Communication with WiFi module not established.”);
}

Serial.println(“Communication with WiFi module established.”);
}

No output is generated. My interpretation is, that the WiFi.status function is called but does not return.
I get the same behaviour with other WiFi functions (like WiFi.begin (ssid, pass) ).

Kind regards

Gert

Please use code tags (</> button on the toolbar) when you post code or warning/error messages. The reason is that the forum software can interpret parts of your code as markup, leading to confusion, wasted time, and a reduced chance for you to get help with your problem. This will also make it easier to read your code and to copy it to the IDE or editor. Using code tags and other important information is explained in the How to use this forum post. Please read it.

Try this:

#include <WiFiLink.h>


void setup()
{
    //Initialize serial and wait for port to open:
    Serial.begin(9600);
    while (!Serial)
    {
        ; // wait for serial port to connect. Needed for native USB port only
    }

    Serial.println("Program starting.");

    if (WiFi.status() != WL_NO_WIFI_MODULE_COMM)
    {
        Serial.println("Communication with WiFi module not established.");
    }

    Serial.println("Communication with WiFi module established.");
}

It just adds a Serial print before calling WiFi.status() to make sure that the program is running up to that point.

Hello pert,

I have tried what you suggested. Unfortunately I got the same result, that means no output message after calling the WiFi function.

Kind regards

Gert

Is "Program starting." printed to the Serial Monitor?

Yes, the first message ist printed, but nothing else.

You have the source code for the library. You could (after making a backup copy) put some print statements in the library to find out where it's hanging. There are some calls with ominous sounding names like wait_for_slave that may be your culprit.

thank you for your hint, but I am not interested to debug a foreign library, I just want to use it and to focus to the problem, that I actually wanted to solve.

schwingshakl: thank you for your hint, but I am not interested to debug a foreign library, I just want to use it and to focus to the problem, that I actually wanted to solve.

The library doesn't work, so you can't use it. That simple.

Smoewhere I have read that I have tu update the UnoWiFi Firmware. I could install the UnoWiFi Furmware Updater but when I start the updater I get the following error message:

java.lang.Exception: Can't communicate with programmer!

Does someone have any idea what this message could mean?

Hi,

Same issue here. It seems that any call to any WiFi.xxx function makes the program freeze.

I’ve indeed also received advice to upgrade the firmware : http://www.arduino.org/forums/general-discussion?p=5980#p5980

I’ll try that and revert here.

Best regards

PS : just discussed with Dimitriy from Blynk, who confirmed that they currently stopped support from Arduino Uno Wifi as it was << there is a long story with this board as it was made in a “bad” way >>. I guess buying the shield might have been easier…

tcibils:
… << there is a long story with this board as it was made in a “bad” way >>.

it’s true, but with WiFi Link it’s usable. install WiFi Link firmware. the WiFi Link library is just a proxy to functions in rhe firmware

The issue seems to remain…

I have updated the firmware using the following :

Using IDE Arduino 1.8.3, firmware ESP8266 (0.0.3), I’ve reached the window saying “The firmware has been updated!”. The WiFiLink library, used through library manager, is version 1.0.1.

My code is as follows :

#include <WiFiLink.h>


char ssid[] = "WiFiName";
char pass[] = "WiFiPassword";

int status = WL_IDLE_STATUS;


void setup()
{
  Serial.print("1");
  Serial.begin(9600);
  Serial.print("2");
  status = WiFi.begin(ssid, pass); 
  Serial.print("3");
  Serial.print(WiFi.status());
}

void loop() {}

And the result printed are “12”, as if the “WiFi” functions freeze everything.

Would someone have an idea of why the issue remains…? Maybe I didn’t upgrade the firware correctly ?

not the right firmware. full answer on arduino.org forum http://www.arduino.org/forums/general-discussion?p=6027#p6027

tcibils: Same issue here. It seems that any call to any WiFi.xxx function makes the program freeze.

I've indeed also received advice to upgrade the firmware : http://www.arduino.org/forums/general-discussion?p=5980#p5980

Hi,

Specifically created an account to say thank you! This has been driving me nuts; I couldn't establish a connection using the regular firmware so tried flashing WifiLink; then I had the freezing problem, so flashed master... and now it works!

Next step will be to integrate OTA flashing into the 'master' build, as per instructions... but for now, I have outbound TCP, which is fantastic.

Thank you :-)

-H

I have something new for Uno WiFi. someone willing to test it?

Hello,

I updated my Arduino Uno WiFi firmware to 0.0.3. I checked many libraries including the above proposed by Juraj. Every script that I create freezes at line WiFi.begin(ssid, pass).

Anyone found the solution for this issue? I bought the board over 2 year ago and I remember I worked well. Now I wanted to use it in my latest project but unfortunately the WiFi module is dead :(