Arduino Uno Wifi Rev 2: upload never ends

I've been using my recently bought Arduino Uno Wifi Rev 2 (original, from a good supplier) for a month. Worked perfectly fine on the Lenovo laptop and I've been able to upload any sketch. Took a break and bought a second one for development so I can deploy the other for actual work.

Started Web Editor today and attempted to upload a sketch to the first Arduino, on COM4 and Arduino Create (the web app) detected it. 'Upload and save' button works but then shows 'Busy' forever and never ends.

I've changed COM ports, restarted Create and the Arduino (hard and reset switch) dozens of times. I've attempted to upload own sketches and simple examples. I've plugged a power supply in addition to the USB power. Same problem.

I connected the new (never used) Arduino Uno Wifi Rev 2 with a new USB cable to my Latitude E7450. Same problem. What???

So all is new but upload is still not possible and hangs. I suspect a problem with Creator so updated Chrome to newest version. Still no upload. Checked the web extensively for any related reports.

I'm all out of ideas.


Debug console:

{"Version" : "1.1.81"} {"Commands" : ["list", "open [portName] [baud] [bufferAlgorithm (optional)]", "send [portName] [cmd]", "sendnobuf [portName] [cmd]", "close [portName]", "bufferalgorithms", "baudrates", "restart", "exit", "program [portName] [board:name] [$path/to/filename/without/extension]", "programfromurl [portName] [board:name] [urlToHexFile]"]} {"Hostname" : "MARMARA-DP"} {"OS" : "windows"} downloadtool windows-drivers latest arduino keep downloadtool bossac 1.7.0 arduino keep list { "Ports": [], "Network": true } { "Ports": [ { "Name": "COM4", "SerialNumber": "", "DeviceClass": "", "IsOpen": false, "IsPrimary": false, "Baud": 0, "BufferAlgorithm": "", "Ver": "1.1.81", "NetworkPort": false, "VendorID": "0x03EB", "ProductID": "0x2145" } ], "Network": false } close COM4 {"Error" : "We could not find the serial port COM4 that you were trying to close."} {"DownloadStatus":"Pending","Msg":"The tool is already present on the system"} {"DownloadStatus":"Pending","Msg":"The tool is already present on the system"} {"DownloadStatus":"Success","Msg":"Map Updated"} {"DownloadStatus":"Success","Msg":"Map Updated"} list { "Ports": [ { "Name": "COM4", "SerialNumber": "", "DeviceClass": "", "IsOpen": false, "IsPrimary": false, "Baud": 0, "BufferAlgorithm": "", "Ver": "1.1.81", "NetworkPort": false, "VendorID": "0x03EB", "ProductID": "0x2145" } ], "Network": false } { "Ports": [], "Network": true } list { "Ports": [ { "Name": "COM4", "SerialNumber": "", "DeviceClass": "", "IsOpen": false, "IsPrimary": false, "Baud": 0, "BufferAlgorithm": "", "Ver": "1.1.81", "NetworkPort": false, "VendorID": "0x03EB", "ProductID": "0x2145" } ], "Network": false } { "Ports": [], "Network": true } {


Messages:

Compiling core...

/home/ubuntu/opt/tools/avr-gcc/5.4.0-atmel3.6.1-arduino2/bin/avr-gcc -c -g -Os -w -std=gnu11 -ffunction-sections -fdata-sections -MMD -flto -fno-fat-lto-objects -mmcu=atmega4809 -DF_CPU=16000000L -DARDUINO=10611 -DARDUINO_AVR_UNO_WIFI_REV2 -DARDUINO_ARCH_MEGAAVR -DUNO_WIFI_REV2_328MODE -I/home/ubuntu/opt/cores/arduino/megaavr/cores/arduino/api/deprecated -I/home/ubuntu/opt/cores/arduino/megaavr/cores/arduino -I/home/ubuntu/opt/cores/arduino/megaavr/variants/uno2018 /home/ubuntu/opt/cores/arduino/megaavr/variants/uno2018/variant.c -o /tmp/032166743/build/core/variant.c.o

Using precompiled core: /tmp/core/core_arduino_megaavr_uno2018_mode_on_b3d7f87b3645115c25fed454100b3392.a

Linking everything together...

/home/ubuntu/opt/tools/avr-gcc/5.4.0-atmel3.6.1-arduino2/bin/avr-gcc -w -Os -g -flto -fuse-linker-plugin -Wl,--gc-sections -mmcu=atmega4809 -o /tmp/032166743/build/1_spa_main.ino.elf /tmp/032166743/build/sketch/1_spa_main.ino.cpp.o /tmp/032166743/build/libraries/SPI/SPI.cpp.o /tmp/032166743/build/libraries/time_1_5_0/DateStrings.cpp.o /tmp/032166743/build/libraries/time_1_5_0/Time.cpp.o /tmp/032166743/build/libraries/wifinina_1_3_0/WiFi.cpp.o /tmp/032166743/build/libraries/wifinina_1_3_0/WiFiClient.cpp.o /tmp/032166743/build/libraries/wifinina_1_3_0/WiFiSSLClient.cpp.o /tmp/032166743/build/libraries/wifinina_1_3_0/WiFiServer.cpp.o /tmp/032166743/build/libraries/wifinina_1_3_0/WiFiUdp.cpp.o /tmp/032166743/build/libraries/wifinina_1_3_0/utility/WiFiSocketBuffer.cpp.o /tmp/032166743/build/libraries/wifinina_1_3_0/utility/server_drv.cpp.o /tmp/032166743/build/libraries/wifinina_1_3_0/utility/spi_drv.cpp.o /tmp/032166743/build/libraries/wifinina_1_3_0/utility/wifi_drv.cpp.o /tmp/032166743/build/libraries/OneWire/OneWire.cpp.o /tmp/032166743/build/core/variant.c.o /tmp/032166743/build/../../core/core_arduino_megaavr_uno2018_mode_on_b3d7f87b3645115c25fed454100b3392.a -L/tmp/032166743/build -lm

/home/ubuntu/opt/tools/avr-gcc/5.4.0-atmel3.6.1-arduino2/bin/avr-objcopy -O ihex -j .eeprom --set-section-flags=.eeprom=alloc,load --no-change-warnings --change-section-lma .eeprom=0 /tmp/032166743/build/1_spa_main.ino.elf /tmp/032166743/build/1_spa_main.ino.eep

/home/ubuntu/opt/tools/avr-gcc/5.4.0-atmel3.6.1-arduino2/bin/avr-objcopy -O ihex -R .eeprom /tmp/032166743/build/1_spa_main.ino.elf /tmp/032166743/build/1_spa_main.ino.hex

Multiple libraries were found for "OneWire.h"

Used: /tmp/032166743/custom/OneWire

Not used: /home/ubuntu/opt/libraries/latest/onewire_2_3_4

Not used: /home/ubuntu/opt/libraries/latest/max31850_onewire_1_0_1

Using library SPI at version 1.0 in folder: /home/ubuntu/opt/cores/arduino/megaavr/libraries/SPI

Using library time_1_5_0 at version 1.5 in folder: /home/ubuntu/opt/libraries/latest/time_1_5_0

Using library wifinina_1_3_0 at version 1.3.0 in folder: /home/ubuntu/opt/libraries/latest/wifinina_1_3_0

Using library OneWire at version 2.3.4 in folder: /tmp/032166743/custom/OneWire

/home/ubuntu/opt/tools/avr-gcc/5.4.0-atmel3.6.1-arduino2/bin/avr-size -A /tmp/032166743/build/1_spa_main.ino.elf

Sketch uses 19360 bytes (39%) of program storage space. Maximum is 49152 bytes.

Global variables use 445 bytes (7%) of dynamic memory, leaving 5699 bytes for local variables. Maximum is 6144 bytes.

bottletree: Started Web Creator today

What is "Web Creator"? I haven't heard of that. Would you mind providing a link to it?

Hi Pert. Thanks for picking this error up. I meant the "Create" web app and its integrated Editor. I have updated my original post with the correct names.

Have you tried the standard Arduino IDE to determine whether the issue is specific to Arduino Web Editor?

Yes I have. The IDE works fine. I can successfully upload and run my sketch. I removed and reinstalled 'Arduino Create Agent' and cleared by browser history. Still the same problem. Board is found and I can upload, but 'Busy' never goes away.

I suspect I may not the only one experiencing this. Anyone else please report it too. I'll wait until this escalates by itself and someone fixes the Create web app.

You're quite correct about that. Here is another report of two people having the same issue: http://forum.arduino.cc/index.php?topic=598236.0

Hi Guys,

Even I have the same issue with uno wifi Rev2......did you find the solution for it? It would appreciate if you can let me know.

Thanks in Advance.

The solution for now is to use the desktop IDE rather than the Create web app - just as Pert wrote. That works fine. Anyone aware of a fix please post here.

Hi Guys, Roberto from Arduino dev team here, nasty heisen-bug on our builder service is now fixed :)

You should now be able to build and flash correctly on the Uno WiFi Rev2!

Bests Roberto