Arduino Uno will not upload

Hi,

I have a brand new Dell Inspiron 15 3000 Windows 10 laptop which compiles but does not upload to either an Arduino UNO or Mega. The boards (UNO and Mega) and cable work on my old laptop. The Arduino IDE was fresh installed and the USB port works ok with a USB drive, cell phone, Fitbit, Mouse, etc.

Get Board Info returns “Native serial port, can’t obtain info”
The INO code is a basic Hello World.
I have tried much (all?) of the different help on the internet without success.
I have the same results with an Arduino Mega board.
The loopback test fails.
I have tried direct connects to both the USB 2.0 and 3.0 ports (same result, always COM4).
As a college professor, I have installed quite a few laptops and PCs with the Arduino IDE with great success so this was not expected.

Thanks for the help!
dan

THIS IS THE BUILD OUTPUT:

Arduino: 1.8.13 (Windows 10), Board: “Arduino Uno”
C:\Program Files (x86)\Arduino\arduino-builder -dump-prefs -logger=machine -hardware C:\Program Files (x86)\Arduino\hardware -hardware C:\Users\Dan\AppData\Local\Arduino15\packages -tools C:\Program Files (x86)\Arduino\tools-builder -tools C:\Program Files (x86)\Arduino\hardware\tools\avr -tools C:\Users\Dan\AppData\Local\Arduino15\packages -built-in-libraries C:\Program Files (x86)\Arduino\libraries -libraries C:\Users\Dan\Documents\Arduino\libraries -fqbn=arduino:avr:uno -vid-pid=0000_0000 -ide-version=10813 -build-path C:\Users\Dan\AppData\Local\Temp\arduino_build_485073 -warnings=none -build-cache C:\Users\Dan\AppData\Local\Temp\arduino_cache_744629 -prefs=build.warn_data_percentage=75 -prefs=runtime.tools.arduinoOTA.path=C:\Users\Dan\AppData\Local\Arduino15\packages\arduino\tools\arduinoOTA\1.3.0 -prefs=runtime.tools.arduinoOTA-1.3.0.path=C:\Users\Dan\AppData\Local\Arduino15\packages\arduino\tools\arduinoOTA\1.3.0 -prefs=runtime.tools.avrdude.path=C:\Users\Dan\AppData\Local\Arduino15\packages\arduino\tools\avrdude\6.3.0-arduino17 -prefs=runtime.tools.avrdude-6.3.0-arduino17.path=C:\Users\Dan\AppData\Local\Arduino15\packages\arduino\tools\avrdude\6.3.0-arduino17 -prefs=runtime.tools.avr-gcc.path=C:\Program Files (x86)\Arduino\hardware\tools\avr -prefs=runtime.tools.avr-gcc-7.3.0-atmel3.6.1-arduino7.path=C:\Program Files (x86)\Arduino\hardware\tools\avr -verbose D:\Classes\Hardware Development\Arduino\First_Arduino_Lab\First_Arduino_Lab.ino
C:\Program Files (x86)\Arduino\arduino-builder -compile -logger=machine -hardware C:\Program Files (x86)\Arduino\hardware -hardware C:\Users\Dan\AppData\Local\Arduino15\packages -tools C:\Program Files (x86)\Arduino\tools-builder -tools C:\Program Files (x86)\Arduino\hardware\tools\avr -tools C:\Users\Dan\AppData\Local\Arduino15\packages -built-in-libraries C:\Program Files (x86)\Arduino\libraries -libraries C:\Users\Dan\Documents\Arduino\libraries -fqbn=arduino:avr:uno -vid-pid=0000_0000 -ide-version=10813 -build-path C:\Users\Dan\AppData\Local\Temp\arduino_build_485073 -warnings=none -build-cache C:\Users\Dan\AppData\Local\Temp\arduino_cache_744629 -prefs=build.warn_data_percentage=75 -prefs=runtime.tools.arduinoOTA.path=C:\Users\Dan\AppData\Local\Arduino15\packages\arduino\tools\arduinoOTA\1.3.0 -prefs=runtime.tools.arduinoOTA-1.3.0.path=C:\Users\Dan\AppData\Local\Arduino15\packages\arduino\tools\arduinoOTA\1.3.0 -prefs=runtime.tools.avrdude.path=C:\Users\Dan\AppData\Local\Arduino15\packages\arduino\tools\avrdude\6.3.0-arduino17 -prefs=runtime.tools.avrdude-6.3.0-arduino17.path=C:\Users\Dan\AppData\Local\Arduino15\packages\arduino\tools\avrdude\6.3.0-arduino17 -prefs=runtime.tools.avr-gcc.path=C:\Program Files (x86)\Arduino\hardware\tools\avr -prefs=runtime.tools.avr-gcc-7.3.0-atmel3.6.1-arduino7.path=C:\Program Files (x86)\Arduino\hardware\tools\avr -verbose D:\Classes\Hardware Development\Arduino\First_Arduino_Lab\First_Arduino_Lab.ino
Using board ‘uno’ from platform in folder: C:\Program Files (x86)\Arduino\hardware\arduino\avr
Using core ‘arduino’ from platform in folder: C:\Program Files (x86)\Arduino\hardware\arduino\avr
Detecting libraries used…
“C:\Program Files (x86)\Arduino\hardware\tools\avr/bin/avr-g++” -c -g -Os -w -std=gnu++11 -fpermissive -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics -Wno-error=narrowing -flto -w -x c++ -E -CC -mmcu=atmega328p -DF_CPU=16000000L -DARDUINO=10813 -DARDUINO_AVR_UNO -DARDUINO_ARCH_AVR “-IC:\Program Files (x86)\Arduino\hardware\arduino\avr\cores\arduino” “-IC:\Program Files (x86)\Arduino\hardware\arduino\avr\variants\standard” “C:\Users\Dan\AppData\Local\Temp\arduino_build_485073\sketch\First_Arduino_Lab.ino.cpp” -o nul -DARDUINO_LIB_DISCOVERY_PHASE
Generating function prototypes…
“C:\Program Files (x86)\Arduino\hardware\tools\avr/bin/avr-g++” -c -g -Os -w -std=gnu++11 -fpermissive -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics -Wno-error=narrowing -flto -w -x c++ -E -CC -mmcu=atmega328p -DF_CPU=16000000L -DARDUINO=10813 -DARDUINO_AVR_UNO -DARDUINO_ARCH_AVR “-IC:\Program Files (x86)\Arduino\hardware\arduino\avr\cores\arduino” “-IC:\Program Files (x86)\Arduino\hardware\arduino\avr\variants\standard” “C:\Users\Dan\AppData\Local\Temp\arduino_build_485073\sketch\First_Arduino_Lab.ino.cpp” -o “C:\Users\Dan\AppData\Local\Temp\arduino_build_485073\preproc\ctags_target_for_gcc_minus_e.cpp” -DARDUINO_LIB_DISCOVERY_PHASE
“C:\Program Files (x86)\Arduino\tools-builder\ctags\5.8-arduino11/ctags” -u --language-force=c++ -f - --c+±kinds=svpf --fields=KSTtzns --line-directives “C:\Users\Dan\AppData\Local\Temp\arduino_build_485073\preproc\ctags_target_for_gcc_minus_e.cpp”
Compiling sketch…
“C:\Program Files (x86)\Arduino\hardware\tools\avr/bin/avr-g++” -c -g -Os -w -std=gnu++11 -fpermissive -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics -Wno-error=narrowing -MMD -flto -mmcu=atmega328p -DF_CPU=16000000L -DARDUINO=10813 -DARDUINO_AVR_UNO -DARDUINO_ARCH_AVR “-IC:\Program Files (x86)\Arduino\hardware\arduino\avr\cores\arduino” “-IC:\Program Files (x86)\Arduino\hardware\arduino\avr\variants\standard” “C:\Users\Dan\AppData\Local\Temp\arduino_build_485073\sketch\First_Arduino_Lab.ino.cpp” -o “C:\Users\Dan\AppData\Local\Temp\arduino_build_485073\sketch\First_Arduino_Lab.ino.cpp.o”
Compiling libraries…
Compiling core…
Using precompiled core: C:\Users\Dan\AppData\Local\Temp\arduino_cache_744629\core\core_arduino_avr_uno_0c812875ac70eb4a9b385d8fb077f54c.a
Linking everything together…
“C:\Program Files (x86)\Arduino\hardware\tools\avr/bin/avr-gcc” -w -Os -g -flto -fuse-linker-plugin -Wl,–gc-sections -mmcu=atmega328p -o “C:\Users\Dan\AppData\Local\Temp\arduino_build_485073/First_Arduino_Lab.ino.elf” “C:\Users\Dan\AppData\Local\Temp\arduino_build_485073\sketch\First_Arduino_Lab.ino.cpp.o” “C:\Users\Dan\AppData\Local\Temp\arduino_build_485073/…\arduino_cache_744629\core\core_arduino_avr_uno_0c812875ac70eb4a9b385d8fb077f54c.a” “-LC:\Users\Dan\AppData\Local\Temp\arduino_build_485073” -lm
“C:\Program Files (x86)\Arduino\hardware\tools\avr/bin/avr-objcopy” -O ihex -j .eeprom --set-section-flags=.eeprom=alloc,load --no-change-warnings --change-section-lma .eeprom=0 “C:\Users\Dan\AppData\Local\Temp\arduino_build_485073/First_Arduino_Lab.ino.elf” “C:\Users\Dan\AppData\Local\Temp\arduino_build_485073/First_Arduino_Lab.ino.eep”
“C:\Program Files (x86)\Arduino\hardware\tools\avr/bin/avr-objcopy” -O ihex -R .eeprom “C:\Users\Dan\AppData\Local\Temp\arduino_build_485073/First_Arduino_Lab.ino.elf” “C:\Users\Dan\AppData\Local\Temp\arduino_build_485073/First_Arduino_Lab.ino.hex”
“C:\Program Files (x86)\Arduino\hardware\tools\avr/bin/avr-size” -A “C:\Users\Dan\AppData\Local\Temp\arduino_build_485073/First_Arduino_Lab.ino.elf”
Sketch uses 1642 bytes (5%) of program storage space. Maximum is 32256 bytes.
Global variables use 306 bytes (14%) of dynamic memory, leaving 1742 bytes for local variables. Maximum is 2048 bytes.
C:\Users\Dan\AppData\Local\Arduino15\packages\arduino\tools\avrdude\6.3.0-arduino17/bin/avrdude -CC:\Users\Dan\AppData\Local\Arduino15\packages\arduino\tools\avrdude\6.3.0-arduino17/etc/avrdude.conf -v -patmega328p -carduino -PCOM4 -b115200 -D -Uflash:w:C:\Users\Dan\AppData\Local\Temp\arduino_build_485073/First_Arduino_Lab.ino.hex:i
avrdude: Version 6.3-20190619
Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
Copyright (c) 2007-2014 Joerg Wunsch
System wide configuration file is “C:\Users\Dan\AppData\Local\Arduino15\packages\arduino\tools\avrdude\6.3.0-arduino17/etc/avrdude.conf”
Using Port : COM4
Using Programmer : arduino
Overriding Baud Rate : 115200
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x77
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 2 of 10: not in sync: resp=0x77
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 3 of 10: not in sync: resp=0x77
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 4 of 10: not in sync: resp=0x77
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 5 of 10: not in sync: resp=0x77
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 6 of 10: not in sync: resp=0x77
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 7 of 10: not in sync: resp=0x77
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 8 of 10: not in sync: resp=0x77
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 9 of 10: not in sync: resp=0x77
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0x77

avrdude done. Thank you.

Problem uploading to board. See http://www.arduino.cc/en/Guide/Troubleshooting#upload for suggestions.

Are you using the AVRISP mkII programmer?
Did you update your new PC after first boot?
Did you install the usb driver douring the Arduino IDE installation (maybe trivial)?

I have always used the “Upload” option but I tried the “Upload with Programmer” with AVRISP mkII and it failed also.
Yes, I have rebooted and updated WIndows 10.
Yes, I installed the USB driver during the Arduino installation.

I just uninstalled IDE version 1.8.13, then deleted the remaining Arduino files then reinstalled 1.8.12 and now the IDE doesn’t see COM4 (or any other COMport). I backtracked from 1.8.13 to 1.8.12 because that is what is working on my old (Toshiba) laptop (1.8.13 has the same issue).

The Arduino shows up in Device Manager under “Other Devices” and reports the drivers are not installed and Update Driver fails to find anything.

Thanks for any suggestions!
dan

I also tried to reinstall the USB FTDI USB Driver in the Arduino installation folder (via Device Manager) but it failed saying the drivers could not be found.

C:\Program Files (x86)\Arduino\drivers\FTDI USB Drivers

THIS IS WHAT I DID TO GET THE ARDUINO PORTS TO WORK CORRECTLY.

I purchased a new Dell Inspiron 15 3000 with Windows 10 and “out of the box”, I installed the Arduino IDE and it would not access the USB ports. After many hours and trying everything (?), I was able to get it to work as described below. The most helpful link that helped me get it working was: https://electronics-project-hub.com/arduino-not-detected-and-driver-issues-solved/.

  1. Perform a Clean Boot
    In order to successfully perform a clean boot on Windows 10, you have to be logged on as the administrator. I followed the detailed steps shown here: FIX: Unable to install drivers on Windows 10 [2021 Guide].
    However, these are the abbreviated steps:
    • Go to the search box
    • Type msconfig
    • Select System Configuration
    • Find Services tab
    • Select Hide all Microsoft services box
    • Click Disable all
    • Go to Startup tab
    • Click Open Task Manager
    • Close Task manager then click Ok
    • Reboot your computer
  1. Download and Install the USB drivers from CH341SER.EXE (Apparently required for cloned Arduinos as per https://electronics-project-hub.com/arduino-not-detected-and-driver-issues-solved/). You might want to try skipping this step to see if the official Arduino USB drivers will work.

  2. Install the Arduino IDE

  3. Left-click on: C:\Program Files (x86)\Arduino\Arduino.exe
    Properties | Compatibility | Check “Run this program as an administrator”

  4. Restart Msconfig as above. Go to “General” Tab and select “Normal Startup” then Apply and OK.