Arduino uno with buspirate as a programmer

Don't know if it's exactly a bug.. I have a bus pirate wich I started using as an avr programmer, an arduino duemilanove and a uno. I've noticed that the version of avrdude shipped with the arduino SW doesn't support it already, so I back-uped the original files and used the last official release of avrdude wich support it, made the necessary changes to boards.txt and programmers.txt. I erased the 2 arduinos and used the IDE to burn sketches directly with the buspirtate and it works with both. When I tried to ri upload the bootloader on the 2 voards from IDE, with the duemilanove I found no problems, and the sketch via usb were uploaded just fine. With the uno instead, the programming was ok, while the IDE didn't recognize the board, I first thought of a misprogramming and tried to reload the optiboot bootloader from command line setting also the fuses and getting the same results. I verified the image inside the mega and was correct, so I searched around the internet and found that the arduino ide uses it's own avrdude to upload sketches with the bootloader. Swapped again avrdude and avrdude.config it worked just fine. I don't understand exactly why with the duemilanove it was alright already after programming the mega, with the latest avrdude and not the same for the uno. Any hints?

anyway, I think this thtread should go into the software/Bugs section.. Sorry..