Arduino UNO with Ethernet Sheild - Error Uploading Example Sketch

Hi,

I'm new here and I have been able to do the blink test sketch with my Arduino UNO. I find that when I connect my Ethernet Shield to my UNO I am unable to load up any sketch. I'm using Ubuntu 12 to run the IDE, and have tried multiple solutions. Like pressing the reset button just before the upload. Pressing the reset button after loading the sketch, but the error I'm getting sounds like my computer is unable to even chat with the Arduino. I tried a separate power supply to the board. On the ethernet shield I have the following LED's lite up: Power, Fullo, 100M, LNK, and RX when I do an nmap on my network. I have my network setup to 192.168.1.1, and the Arduino code set for 192.168.1.177. I don't think this matters until I can get the code loaded up on my Arduino.

I get the following when I try to upload the sketch with the ethernet sheild attached:

Using Port      : /dev/ttyUSB0
Using Programmer :   arduino
Overriding Baud Rate :  115200
avrdude: Send: 0 [30]     [20]
avrdude: Send: 0 [30]     [20]
avrdude: Send: 0 [30]     [20]
avrdude: ser_recv(): programmer is not responding
avrdude: stk500_recv(): programmer is not responding

avrdude done.  Thank you

Here is the ethernet shield I have: http://www.ebay.com/itm/Ethernet-Shield-W5100-For-Arduino-Main-Board-2009-UNO-ATMega-328-1280-MEGA2560-/400356634583?ssPageName=ADME:X:AAQ:US:1123

Here is the arduino uno board I have: [Arduino UNO]http://www.ebay.com/itm/291095647106?var=590250102532&ssPageName=STRK:MEWNX:IT&_trksid=p3984.m1497.l2649"]Arduino UNO](http://www.ebay.com/itm/291095647106?var=590250102532&ssPageName=STRK:MEWNX:IT&_trksid=p3984.m1497.l2649")

I don't know what kind of board that is but it is definitely NOT an official Arduino UNO.

Have you tried uploading a simple sketch (like Blink) without anything but USB attached? Does that work?