Arduino Upload Timeout

Hey all, I was working on a simple script for my arduino when suddenly nothing would upload.
I tried uploading basic programs such as blink, and tried swapping cables and arduinos.
It seems that I can't upload to my arduino no matter what I try at this point.
here are the error messages:

Arduino: 1.8.1 (Windows 10), Board: "Arduino/Genuino Uno"

Sketch uses 3370 bytes (10%) of program storage space. Maximum is 32256 bytes.
Global variables use 243 bytes (11%) of dynamic memory, leaving 1805 bytes for local variables. Maximum is 2048 bytes.
C:\Program Files (x86)\Arduino\hardware\tools\avr/bin/avrdude -CC:\Program Files (x86)\Arduino\hardware\tools\avr/etc/avrdude.conf -v -patmega328p -carduino -PCOM3 -b115200 -D -Uflash:w:C:\Users\Bpark\AppData\Local\Temp\arduino_build_312916/Rotary_Final.ino.hex:i

avrdude: Version 6.3, compiled on Dec 16 2016 at 13:33:19
Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
Copyright (c) 2007-2014 Joerg Wunsch

System wide configuration file is "C:\Program Files (x86)\Arduino\hardware\tools\avr/etc/avrdude.conf"

Using Port : COM3
Using Programmer : arduino
Overriding Baud Rate : 115200
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0xee
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 2 of 10: not in sync: resp=0xee
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 3 of 10: not in sync: resp=0xee
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 4 of 10: not in sync: resp=0xee
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 5 of 10: not in sync: resp=0xee
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 6 of 10: not in sync: resp=0xee
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 7 of 10: not in sync: resp=0xee
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 8 of 10: not in sync: resp=0xee
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 9 of 10: not in sync: resp=0xee
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0xee

avrdude done.

Problem uploading to board. See http://www.arduino.cc/en/Guide/Troubleshooting#upload for suggestions.

Some research suggests resetting the firmware, which I have no clue how to do. I have also made sure that there was no "!!!" string in my code(a problem according to a different post).

I made sure that I selected Arduino Uno and chose the correct COM port.

any help would be appreciated, thanks! :slight_smile:

Is anything connected to the 0 or 1 pins? disconnect while uploading if so.

The !!! issue is only relevant to the mega2560 (and if it happens, putting the new bootloader onto the board will fix it)

I had my rotary encoder hooked up to pins 0 and 1... disconnecting it worked!

this is extremely strange, do you know why having pins connected to 0 and/or 1 causes uploads to fail? I don't understand why this is even something that happens.

anyways, thanks!

Those are the TX and RX pins for the serial port; sketches uploaded normally are uploaded via the serial port.