Arduino uploads sketches, but doesn't run it

Hi,

I've been trying during all day to make my Arduino board works.

I'm trying to run the SpaceshipInterface sketch. It uploads to the board, but nothing happens afterwards.

I tried the blink project and it is ok. The L, RX and TX are also ok. Every time I upload the sketch, the L led on the board blinks three times, very fast. I read here on the forum that this is the expected behavior.

I reviewed the project a hundred times and the IDE shows no error messaging. Just tells that the uploading is done and everything else is fine.

So, I really don't know what to do. And it is very frustrating... :frowning:

Any help will be appreciated.

My os is El Captain 10.11.3
My board is the Arduino UNO
The usb port is dev.cu.usbmodem1411
The programmer is AVRISP mkll

Two things are needed before we can really help:-

  1. Post your code, using code tags, so we know what you're referring to.

  2. A clear photo of your setup would help, so we can double-check your connections.

It uploads to the board, but nothing happens afterwards.

Do you mean that no LEDs are lit at all?

Edit: You say that the programmer is "AVRISP mkll". Are you really using ISP to upload the sketch, or using the Arduino IDE to upload serially via the "Upload" button? (The programmer will show in the output window as "Arduino", and the programmer shown in the IDE under >Tools >Programmer will not actually be used.)

When you upload, the one LED should flash 3 times *as you observe) after which the RX/TX Leds should flash for a while during the transfer of the code to the board. Once the transfer of the code is completed, you should see a message in the 'title bar' of the output window saying something in the line of 'upload done'.

If that all happens

Start with the Blink sketch. You say it works. Next modify the delays (e.g. from 1000 to 2000); does it still work as expected?

Next take another sketch; upload it. Does it work as expected?

If the answer to both is yes, it's your sketch. Post it using code tags

type
** **[code]** **

paste your code after that
type
** **[/code]** **

I found that sketch, in the IDE under >Examples >StarterKit >p02_SpaceshipInterface

@jaspier, if you typed it in manually for your first test, you could try uploading the copy above and see if it works. If not, you can expect the problem to be in your circuit.

Hi,

I tried upload straight from the examples folder. It didn't work. I attached a picture of the arduino and the breadboard. I think I followed correctly all the information in the book.

If it is really a problema on the circuit, what I need to do to solve it?

Thank you all!

Sorry, here follows the attachment.

Heya!

Here is a small idea;
That example looks like it wont do anything until the button is pressed, so maybe there is a problem with the button?
So is the button connected in the correct orientation?

might the led's be orientated backwards? try flipping one or two of them just in case(if it does nothing then you probably have them right :smiley: ,go ahead and flip them back)
Note: When viewing an led from the side, the larger piece of metal gets connected to ground(I didn't know if the example goes over that).

I cant help but notice that the built in led on pin 13 is lit up yet nothing in the arduino example calls for that pin, this makes me wonder if something in specifically your code is awry.

Hope this helps any bit!
sorry for ya troubles:/

I can't tell for sure with the other two, but the LED on the right is definitely connected backwards. Spin it around and double-check that the other two are correct. The flat side of a LED is the cathode, (negative).

Tech-guy:
might the led's be orientated backwards?

You got it.

Hi,

I did the changes. Everything is ok now!

Thank you guys!