arduino v18 linux editor font problem

the editor font looks terrible, hardly readable. i've tried editing two different preferences.txt file and one theme.txt file. nothing seems to change these fonts. i am running ubuntu linux v9.10

any help is greatly appreciated.

Thanks Jeff

Hi, you can set the size of the font in the preferences-dialog File->Prerences or edit the file that is mentioned on the dialog.

Some stupid code in the IDE seems to switch off font antialiasing on the editor. So you can't really use any sensible Font in the IDE. 'Inconsolata' looks horrible for instance. So I'm back to monospaced size 18.

Eberhard

so is somebody working on fixing this for linux? because it looks wonderful on the mac.

also is it really spelled Monospaced and not Monospace. and for what it's worth i tried changing the spelling and it makes absolutely no difference which leads me to believe that it is ignoring this setting anyway. in fact you can even time garbage in these font fields and it will still look the same. hmmmm......

Jeff

so is somebody working on fixing this for linux?

No. Arduino GUI-Development stops when it looks good on a Mac and Windows.

The IDE is the only GUI-editor on the planet (probably in the whole universe) that does not have a font-selection dialog.

Eberhard

is there somewhere that we can send a feature request to?

Bug reports go here

http://code.google.com/p/arduino/issues/list

Eberhard

I am running V18 on Ubuntu 9.10 as well and the UI looks pretty good to me. I am wondering if you somehow changed your system font settings or are using some kind of themes?

can you email me off list your preferences.txt file?

what font does it say you are using?

also how do you change the system font? i don't even know how to do this.

Thanks Jeff

Here are the fonts settings (I don't remember ever changing them, so they must be the default:)

editor.font=Monospaced,plain,12 editor.font.macosx=Monaco,plain,10

And here's the whole preference.txt (note that I have removed some file paths specific to my settings):

update.id=395532480225780957 target=arduino export.application.platform.windows=true preproc.save_build_files=false preproc.substitute_floats=true run.options= run.display=1 editor.divider.size=0 serial.port=/dev/ttyUSB1 preproc.enhanced_casting=true editor.divider.size.windows=2 browser=mozilla last.sketch2.location=858,83,1000,1000,828 last.sketch1.path= editor.font=Monospaced,plain,12 console.auto_clear=true console.output.file=stdout.txt last.sketch.count=0 export.application.platform=true default.window.height=1000 export.application.stop=true serial.parity=N serial.databits=8 board=atmega328 preproc.output_parse_tree=false editor.external=false editor.indent=true last.screen.height=1200 upload.using=bootloader run.present.bgcolor=#666666 preproc.web_colors=true editor.tabs.expand=true run.present.stop.color=#cccccc preproc.color_datatype=true last.screen.width=1920 export.application.platform.linux=true launcher=gnome-open export.application.platform.macosx=true editor.antialias=false export.applet.separate_jar_files=false editor.tabs.size=2 console.error.file=stderr.txt preproc.substitute_unicode=true console=true run.present.exclusive.macosx=true console.lines=4 run.options.memory.maximum=256 browser.linux=mozilla preproc.imports=java.applet,java.awt,java.awt.image,java.awt.event,java.io,java.net,java.text,java.util,java.util.zip,java.util.regex update.check=true last.sketch0.path= last.sketch2.path= run.window.bgcolor=#DFDFDF sketchbook.path= last.sketch0.location=510,150,1000,1000,828 update.last=1271635400408 export.delete_target_folder=true platform.auto_file_type_associations=true default.window.width=1000 editor.caret.blink=true serial.stopbits=1 serial.debug_rate=9600 run.options.memory.initial=64 run.options.memory=false last.sketch1.location=510,150,1000,1000,828 editor.invalid=false editor.font.macosx=Monaco,plain,10 export.application.fullscreen=false console.length=500 run.present.exclusive=false

mine is basically identical. hmm…
do you know the proper way to uninstall and reinstall?

By any chance you can post the screenshot of your Arduino IDE? Anyway, assuming that you installed your Arduino using apt-get, you might want to first remove it (apt-get remove...) and then download the latest version directly from http://arduino.cc/en/Main/Software.

I downloaded mine directly and didn't use apt-get.

not sure how top add attachments to forum post?

This is what you're aiming for : This is on Ubuntu 9.10

You need to put the screen shot on a separate hosting site (flickr for example) and then use the insert image button and add the URL between the directives that are added.

Using ubuntu 9.10 aswell, my IDE looks the same as posted by pluggy. So doesn't appear to be a bug inherint in ubuntu.

I noticed today that the editor fonts looked really bad on karmic 9.10 and they were fine last time I used the IDE.

I think there was a sun JDK 6 update last week sometime and I bet that's the problem.

Anyway, I found that changing editor.antialias in the preferences.txt file made it look much better. It was: editor.antialias=false and I changed it to: editor.antialias=true

Much better.

thanks i will give this a try.

i guess my other problem is this. has anybody been able to change the font to anything other than Monospced?

It seems to work for me. I can change the editor font by changing the editor.font property

for example: editor.font=Andale Mono,plain,14

in 9.10 there is a monospaced font named Monospace (vs Monospaced) that looks a little better (in my opinion).

binkl.

I notice that the font sizes in the Arduino IDE are not at all consistent with font point sizes in the rest of Ubuntu/Gnome 10.04. For instance, font Droid Sans Mono, plain, size 12 in Arduino is much smaller than 12 point Droid Sans Mono is in every other application.

I may have to take a look at this myself since no one is fixing it and it's terribly ugly without antialiasing.

Try change the editor font to 14

editor.font=Monospaced,plain,14

in ./arduino/preference.txt

Even though I didn't have any problem in Ubuntu 9.10 I did notice problems in 10.04 and with the default font size, the _'s are not displaying properly. But after increasing the font size to 14, everything looks pretty good.