Arduino version and Mac OSX 10.8.2

I have just upgraded my 15" MacBook Pro to Mac OS X v. 10.8.2
What version of the Arduino software should I use? I can't find any info on compatibility with Mac OS X 10.8.2 and Arduino v. 1.0.3 or v.1.5.2 beta.
I would be using an Uno v. 3 or a Nano.

Thanks,

George

Mine worked just fine with the latest 1.0.3. Running 10.8.2 as well. It's stopped working now, but I think it's an issue with the board and not the software. I could be wrong though.

OSX Version doesn't matter.

1.5.2 should only be used if working with the new Due board.