Arduino Web Editor lost my sketch content

Hi,
Some of my sketch contents become blank for no reason. Is there any ways to retrieve them back? Thanks!

Most of the team are off this week but I have left a note in case anyone comes by and logs in.

Short answer is YES they can often get them back.

Bad news is I dont know when.

This has happened to me as well.

Is there a error with the editor?

It's only the first file that's blank - additional files within a sketch folder seem fine.

Considering the huge user base for CREATE this is a very rare issue but be assured the team is aware of it and in most cases the original sketch can be restored.

The first file being blank or almost blank is the common thing with these AWOL sketches.

As to the actual cause its almost impossible to know if its a server or editor issue which makes chasing it so difficult.

I tend to keep incremental copies of sketches after any large changes/developments to make sure I can backtrack if needed.
Most programmers keep to a regime of version control even if its just adding a couple of numbers to the end of a sketch / programme before saving and making sure they save on a regular basis.

Thanks for your reply! I surely will keep a copy locally from now on. I just thought the cloud storage should be more reliable and convenient, otherwise users could just use the editor on their computer.
I'd appreciate it if version control can be added to the web service. Maybe a link to GITHub is a good idea.

I Agree.

I had assumed the cloud storage was automatically stored on several (at least 2) servers, therefore more dependable than using my local dive.

I'm able to work on my sketches during downtime at work, but not able to install anything on the work computer, so I have really been happy to have the online editor as an option. Saving locally isn't really an option here. Being able to link/update a github depository or something would be handy.

Currently, I'm really hoping that my file can be recovered - It was completely written on non-home computers, so I don't have any other copies. I CAN probably recreate it, but I'd rather not have to spend the time on work I've already done.

Sorry for Hijacking this thread, but this happened to me as well just now.
What would be the best course of action? How and who should I contact to try to retrieve my sketch?

@TL-Almax

In this case its not hijacking and I am glad you put your post here.

It helps when they can get an idea of the amount of people affected.

I tried to make a copy of the sketch that is missing the first file - partly as a backup and partly to work on recreating the contents of that first file...

The web editor had a message saying it had an error in attempting to save.

If I exit and come back, there is no copied sketch.

I'm afraid to open any other sketches, just in case that triggers a loss of data in the other files.

Any suggestions?

So far the issue tends to isolate itself to a single sketch.

Leave the damaged sketch in your sketchbook and dont delete it !
That will also give the team the best chance to restore it as the filename may be useful and you may be asked for the SHARE URL / address.

Have seen the issue myself and in my case it always seems to be the same sketch.

If I delete it and then replace it with a backup copy it seems to eventually send that sketch AWOL too.

However if I leave the damaged sketch alone then so far it has not affected other sketches.
As mentioned it is always a good idea to do some sort of "version" control and if the sketch is very important then downloading it to your computer as a true backup is another very good idea.

Hopefully some of the team will be back on Monday so they can investigate further and restore some of the sketches for users.

It also does not seem to affect the second tab if you use more than one tab so another option would be to copy paste the sketch itself to another tab but name that tab as xxxx.TXT or xxxx.ADOC so it is treated as a text file.

As a possible (no guarantee) fix wait for a few moments after you have seen the SAVED message and then save again and wait a few moments after the next SAVED msg. Then try to REFRESH the page rather than close it. If the sketch is still there then there may be a better chance it got sent to the servers correctly.

I know these measures don't help you all at the moment but until somebody comes back in it is the best I can offer you at the moment.
BTW I am not employed by Arduino I just play with CREATE a LOT as a tester.

Please, when something like this happens, write to support@arduino.cc with the url of the sketch, so that we may verify what happened

Just happened to me. Sending email to support as previous post requested.

Me too. Lost my work, right before I need to display it. Pretty upset at this.

@MarkTheCaz

Please supply the SHARE URL/LINK as suggested by Matteo

Glad I found this topic bacause yesterday I was messing with a sketch on the online editor (Arduino Create) and it was fine however today I went to access it and make some modifications but all of the code in my sketch is missing, basically its an empty sketch now. Oddly enough the second tab is untouched. I was wondering if

1- Is there any type of version control on the editor that I could roll back to;
2- Is there any way I can doenload the code from the arduino without external devices (I know I'd have to first convert to assembly then convert to C++);


In the meantime I'm sending an email as suggested w/ the shared link of my sketch.

Hi Dark_sat

Currently there is no "real" version control so a roll back would be a little difficult.

Presently you can simply re-save any code you are worked on using the SAVE AS option.
That will put "_COPY" at the end but you may want to change that to such as "Vnn" or something that suits you.

Generally the bug only affects a single sketch and some countermeasures were put in place to mitigate the problem as much as possible.

However as you found out these are not yet perfect.

It is possible to download the original compiled HEX file from a device but IIRC it will give you a PRE-COMPILED file.