arduino wifi shield PROBLEM

Hi Guys,

I am having some trouble with updating the wifi shield firmware.

I am trying to update as per this link http://arduino.cc/en/Hacking/WiFiShieldFirmwareUpgrading#.UwCTe4XHTep

here I go,

Hardware setup - The PC is connected to arduino wifi shield via mini USB, arduino 2560 not connected.

I clinked on link to update firmware for the 32UC3A1256 using the github link but cant find the wifi shield firmware folder that needs to be downloaded. ( am i missing something obvious?)

I do notice that in my arduino software folder i have a folder called wifishield firmware, so i thought I already have it and I should keep moving.

Then I get to cmd prompt where I have to enter this

“batchisp.exe -device AT32UC3A1256 -hardware usb -operation erase f memory flash blankcheck loadbuffer /Arduino/hardware/arduino/firmware/wifishield/binary/wifi_dnld.elf program verify start reset 0”

as soon as I do this I get error saying JVM.dll cant be loaded and another one saying MSVCR100.dll cant be found. see attached pic.

So I get online and download a JVM.dll fixer and downloaded MSVCR100.dll from this link as advised http://www.tomshardware.com/forum/36518-63-msvcr100-missing-computer

once I have saved and run these I go back to cmd prompt and same error msgs appear.

any thoughts?

(thanks to surferTim if he is reading this in advance)

I think you are missing Java. The jvm.dll is the java virtual machine. http://en.wikipedia.org/wiki/Java_virtual_machine It is probably telling you that it needs Java installed.

Hi tim,

I already have Java installed on my computer.

I had a similar problem earlier when I was setting eclipse on my PC and it said Java.dll not loading, but that was solved by downloading Java for a 64bit PC and also redirectng the new location of Java.dll

The way I am updating firmware for wifi shield, do I need to redirect the path somehow? I just had a look at my Java bin and looks like I have Java.dll and MSVCR100.dll files but somehow I believe "whatever" is trying to run cant find the location of these java files?

Hi Tim,

something very interesting happened, i copied Jvm.dll and MSVCR100.dll files from Java folder and saved in bin location for flip.

I entered the first cmd prompt and

…it responded with the following, see attached.

any thoughts ? what port fail means or is this what I should see until i enter the next cmd prompt…

I never got that error. Are you certain you have the jumper pins connected with the jumper block on the wifi shield? Those are the pins next to the SD card slot. To program the firmware, they need to be connected (jumpered). To works as the wifi shield, they must be disconnected.

Hi Tim and all ,

Yep, definitely got J3 shorted :).

I managed to get a little further as well.

So once I copied and pasted the 2x.elf files I had to restart the computer and then I got another error stating I was missing some other dll file, googled it and found out that I needed to manually click on update the driver and locate this to atmel usb driver folder , which I did and this fixed this error.

Anyhow the latest msg says

Parsing ELF file… Can’t open input file “/Arduino/hardware
/arduino/firmware/wifishield/binary/wifi_dnld.elf”

when it should actually say ( found this link http://www.binarytaskforce.com/Weblog/2013/09/21/arduino-wifi-firmware-update/)

Parsing ELF file… PASS c:/wifi_dnld.elf
WARNING: The user program and the bootloader overlap!

So i went on looking for some solution and found this old link http://forum.arduino.cc/index.php/topic,183484.0.html

and tried these steps,

  1. copied the two elf files in root directory, this didnt fix the error.
  2. I then tried deleting these two elf files from arduino folder and replaced them with ludgy’s one as per this link http://forum.arduino.cc/index.php?PHPSESSID=0g864usaihcj5af5uckifaso93&topic=180445.0
    and this didn’t work.

I am pretty sure either it is unable to open it due to lack of location or the file is corrupt, I am use v1.0.5, should I be using v1.0.2 or something…

I dont have anything else I can try … any thoughts guys?? (thanks Tim as always)

Hi guys and ofc Tim,

I went and tried what Tim said on one of his posts here http://forum.arduino.cc/index.php/topic,216104.0.html

so copied the elf files in root directory but realized that tim had also changed the location ( I feel like an idiot) so once I noticed that I copied the new location and wait for it

IT WORKED!

BUT.. however when I ran the first command the arduino wifi shield after successful implementation disconnected itself from PC and I had to pull the USB and connect again to run the second prompt into the cmd.

Is this how it should be??