Arduino won´t write inside the file created.

Hi there mates,

I´ve gotta a bit of a problem here that is messing with my head real bad. I´m trying to log some data for another program I´m building, in an SD card. Thing is that, before going deep I tried the Read and Write example. Apparently everything works just fine as expected, everything is connected as it should in the Arduino UNO board and the Shield (using CS as 10), and I manage to create the file, but no matter what, I just can´t write into it.
I´ve tried two libraries, the SD.h and the sdfatlib.h but it´s everytime the same thing, file will create but it will be 0 bytes when I try to open it in my computer. I´ve tested it on a Mac using the latest release 10.8.2, and Windows 7, but on this last one I had even more difficulties.
The SD shield is a generic one from LC studio (cheap)
I´m using a 1 GB microSD card into an SD adaptor, formatted as FAT32 and tested it using the first example from the SD Library "card info" and everything seems to be fine.
Here is a screen shot:

Any of you guys have had this same problem before? I´ve tried everyhting I´ve seen online, searched everywhere but all I can find is orientation on how to connect pins and all that I already know.
Thanks in advance.

If someone owed you money, would you be satisfied if they sent you a picture of the money? We aren't satisfied with pictures of code, either.

Where's the serial debug information?