Arduino wont communicate through usb

It was working fine and well but I tried connecting it to a USB cable that only had power and ground cables in it the data cables were removed. this was to test another problem that isn't relevant to this. after this it won't show up on any port or in the device manager. I don't think it's even trying to communicate over USB now but I'm very unsure. it's an Uno wifi r2

plz help, I'm doing Mark Robers engineering course and need it to work for that.

Run the loopback test.

has no affect, nor the TX or RX lights flash. it wont show up in any port

Looks like you may have damaged the USB chip.

Did you try a different USB interface cable ?

i tried it with another usb b cable i had

i think i may have damaged it from using a 9v battery into the usb port that is probably the issue
is it fixable or at least is there a workaround

If 9v was applied to the 5v bus, all bets are off.
:sleepy:

Get a new Arduino.

ok I understand, thanks for the help

FYI, the loopback test is not applicable on Uno WiFi Rev2. The reason is pins 0 and 1 are Serial1, separate from the dedicated Serial interface between the board and the computer.

Does the Uno WiFi Rev2 show any signs it is getting power? The power input from the USB connector goes through a polyfuse followed by an inductor, then has a zener diode to ground that should protect against overvoltage (although I have not found a reference to what the zener voltage is). A direct connection to a 9v battery may have either damaged the USB connector itself, the polyfuse, or the inductor.

Yes it still powers up fine over usb and runs last imported code fine. It just doesn’t send any data through usb

The Uno WiFi Rev 2 uses an atmega32u4 for the USB to serial interface. That has a direct connection to the voltage input from the USB connector, so may have been damaged.