Arduino won't take code

Hey all!

I have 3 Arduino Nanos, and I’ve used two of them. I uploaded a FastLed program to control LEDS and it worked, but when I tried to re-upload anything, it gives me this error:

avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 6 of 10: not in sync: resp=0xff
avrdude: ser_send(): write error: sorry no info avail
avrdude: ser_recv(): read error: Access is denied.

The original code:

#include <FastLED.h>

#define PIN 3
#define NUM_LEDS 33

CRGBArray<NUM_LEDS> leds;
uint8_t hue[NUM_LEDS];

void setup() {
  FastLED.addLeds<NEOPIXEL, PIN>(leds, NUM_LEDS);
  for (int i = 0; i < NUM_LEDS; i++)
  {
    hue[i] = 255 / NUM_LEDS * i;
  }
}

void loop() {
  for (int i = 0; i < NUM_LEDS; i++)
  {
    leds[i] = CHSV(hue[i]--, 255, 255); //Color saturation brightness
  }
  FastLED.show();

}

It looks like this is also an error: (Nevermind)

In file included from C:\Users\ajgri\OneDrive\Desktop\Wave\Wave.ino:1:0:

C:\Users\ajgri\OneDrive\Documents\Arduino\libraries\FastLED-master/FastLED.h:17:21: note: #pragma message: FastLED version 3.001.008

 #    pragma message "FastLED version 3.001.008"

                     ^

Compiling libraries...
Compiling library "FastLED-master"
Using previously compiled file: C:\Users\ajgri\AppData\Local\Temp\arduino_build_455205\libraries\FastLED-master\FastLED.cpp.o 
Along with many other .cpp.o files in the Fast LED library

I am using 33 LEDS for 400MA and the board should support 800MA at 5V: Stack exchange where I found this
I am using the A328P bootloader, but I have tried the other two
I’m also pretty sure it’s a clone as it doesn’t say nano on it

What I’ve tried:
Using a new Arduino
Updating drivers
A different cable
A different computer
Uninstalling and reinstalling drivers
A different programmer (Note: I’m not uploading using programmer)
Uploading a blank program
Pressing the reset button while uploading code

What I haven’t tried:
Burn the bootloader and reinstall using the third one (I’m not technically advanced enough to do this, but I have a friend who can help me on Friday.)
I have since hooked up a separate power supply, but did I fry two of my boards?

The pragma message is NOT an error.

Nanos have newer options (IDE dependant)

Check if you need to use what is now termed "old bootloader" when you select the NANO from the drop down board menu and the sub menu from there.

Avoid USB 3.0 ports.

I have tried using the old bootloader, still no luck. I am using a 3.0 port, because that is all I have, but I can try to use a 2.0 and the arduino IDE. Also, I didn't know if it was an error, thanks!