arduino yun and usb/serial device firmware issue

Hi,
i am trying to interface the linux side of the yun with an RFID reader (texas instruments tiris s2000) that incorporates the TUSB3410 USB/Serial device.

Texas instruments indicate that driver support for this device has been in the linux kernel since ver. 2.6. I have the latest version of WRT on the yun (1.5.3) which has kernel version 3.3.8.

I have tried the device on my normal linux box and it works fine and gets setup on /dev/ttyUSBX. HOwever this is not happening on the linux version in the Yun

Relavent output from dmesg | tail is below;

root@Arduino:/# dmesg | tail
[ 41.610000] fuse init (API version 7.18)
[ 442.680000] usb 1-1.1: new full-speed USB device number 4 using ehci-platform
[ 442.820000] usb 1-1.1: New USB device found, idVendor=0451, idProduct=3410
[ 442.830000] usb 1-1.1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 442.830000] usb 1-1.1: Product: TUSB3410 Boot Device
[ 442.830000] usb 1-1.1: Manufacturer: Texas Instruments
[ 442.840000] usb 1-1.1: SerialNumber: TUSB3410
[ 442.840000] ti_usb_3410_5052 1-1.1:1.0: TI USB 3410 1 port adapter converter detected
[ 443.080000] usb 1-1.1: ti_download_firmware - firmware not found
[ 443.080000] ti_usb_3410_5052: probe of 1-1.1:1.0 failed with error -5

If i read this output correctly, it looks like the drivers are present but it is missing some firmware. Since it is working fine on my linux box the firmware must be present - so could i use the firmware from my linux box and where would i find it.

Any help is much appreciated.

Cheers.